Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I already tried FORMAT /FS:FAT, diskpart, Disk Management and HP USB Disk Storage Format Tool.

Do I really need to buy a smaller capacity drive? Can't a formatting tool ignore the area beyond 2 GB?

My Asus netbook's BIOS update requires the USB to be formatted as FAT16, and I couldn't get the various Asus BIOS update utilities to work.

share|improve this question
That is an awful restriction on that BIOS flash, yeesh. I'd write them a letter... –  Shinrai Oct 22 '10 at 15:16
Ken's method works. However the uncooperative Asus bios updater still couldn't read it. I solved my problem by creating a "make MS-DOS bootable" USB stick and using the AFUDOS utility. AFUDOS updated the BIOS in a jiff. –  William C Oct 25 '10 at 3:52

4 Answers 4

Disk Management and DISKPART don't let you delete partitions on removable media. But you can use DISKPART's clean command to nuke it and start over. Here is a series of commands that worked for me:

DISKPART> list disk

  Disk ###  Status      Size     Free     Dyn  Gpt
  --------  ----------  -------  -------  ---  ---
  Disk 0    Online        40 GB      0 B
  Disk 1    Online      7538 MB      0 B

DISKPART> select disk 1

Disk 1 is now the selected disk.

DISKPART> list part

  Partition ###  Type              Size     Offset
  -------------  ----------------  -------  -------
  Partition 1    Primary            500 MB  1024 KB


DiskPart succeeded in cleaning the disk.

DISKPART> create part primary size=500

DiskPart succeeded in creating the specified partition.

DISKPART> active

DiskPart marked the current partition as active.

DISKPART> format fs=fat quick

  100 percent completed

DiskPart successfully formatted the volume.

DISKPART> assign

DiskPart successfully assigned the drive letter or mount point.

This creates a 500MB FAT partition as the only one on the disk. list part is only used to make sure I selected the right disk (and the Size shown was from a previous attempt; yours will say something else closer to the full size).

share|improve this answer
Okay, this worked because it created me a 500MB usb drive. "FORMAT /FS:FAT" even works on it now, ably reformatting it to 500MB. However, the silly Asus onboard BIOS update program recognizes the drive but can't find the rom file I saved in it. I repeated the whole thing with "create part primary size=1" and then re-FORMAT /FS:FAT-ted it but still the asus update tool can't find my rom file. Do you have any further suggestions? –  William C Oct 22 '10 at 18:45
Is it supposedly listing the contents of the drive, but the list is empty? Use DIR /X to verify that the file has a simple 8.3 file name with the correct extension, all in uppercase. Create some bogus files (like with echo > TEST.ONE), some with the correct extension, and see if they appear. –  Ken Oct 22 '10 at 21:20
No. The bios utility just says, "USB device found. // Reading "1000HE.ROM"... // Can't find "1000HE.ROM" on the USB device!" I tried renaming it to "1000he.rom" or "1000he.ROM" or "1000HE.ROM". Past EEEPC Forum discussions instruct updating the bios in XP first (because there's an Asus BIOS Updater that runs in XP) before installing Windows 7. I might just have to look for someone who has a 1GB usb stick. –  William C Oct 22 '10 at 22:26
I have an ancient 8MB USB key, and it does not have a partition table at all. It's just like a floppy: the boot sector is the first sector, followed by the FAT and root directory. It's easier to read, and maybe what the Asus BIOS is expecting. Try putting the ROM on a floppy, then do a sector copy (like with dd) over the first sectors of the USB, and try that. For more help, open another question; your original one seems to be answered. –  Ken Oct 23 '10 at 0:42
Yes it was. Thank you, Ken! –  William C Oct 25 '10 at 3:49

There isn't any way to format a FAT16 partition larger than 4 GB (2 GB under Windows). Use a partitioning tool to repartition the drive (you may need Linux for this).

share|improve this answer

Linux mkdosfs for Windows NT/2K/XP ranks pretty highly on Google when searching for "mkdosfs".

Seems like exactly what you're looking for.

share|improve this answer

Try Create a DOS Bootable USB drive (using grub4dos) suitable for BIOS flashing. It worked for me.

It was real easy to use with good instructions.

share|improve this answer
please include the vital contents from the link in your own answer. if the link ever gets broken so does your whole answer. –  Lorenzo Von Matterhorn Dec 4 '13 at 22:49

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.