Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I want to install the latest version of Git using yum and the RPM repository on kernel.org, but adding the repo to yum.repos.d causes yum to fail with checksum errors.

The prevailing solution to this issue seems to be to simply use the repository at Webtatic as answered here on superuser. I know I can also install an older version of Git using the EPEL repo, or compile from the latest source tarball, but honestly I want to understand why I'm having issues using the kernel.org repo.

Here’s the workflow, after a clean install of CentOS 5.5 and "yum update":

[root]# wget -P /etc/yum.repos.d/ http://kernel.org/pub/software/scm/git/RPMS/git.repo  
[root]# yum clean all  
[root]# yum repolist   
Loaded plugins: fastestmirror  
Determining fastest mirrors  
 * addons: mirrors.netdna.com  
 * base: mirror.clarkson.edu  
 * epel: serverbeach1.fedoraproject.org  
 * extras: centos.mirror.nac.net  
 * updates: mirror.cogentco.com  
addons            |  951 B     00:00       
addons/primary    |  202 B     00:00       
base              | 2.1 kB     00:00       
base/primary_db   | 1.6 MB     00:01       
epel              | 3.7 kB     00:00       
epel/primary_db   | 2.8 MB     00:01       
extras            | 2.1 kB     00:00       
extras/primary_db | 188 kB     00:00       
git               | 1.2 kB     00:00       
git/primary       | 155 kB     00:00       
http://www.kernel.org/pub/software/scm/git/RPMS/i386/repodata/primary.xml.gz: [Errno -3] Error performing checksum  
Trying other mirror.  
git/primary       | 155 kB     00:00       
http://www.kernel.org/pub/software/scm/git/RPMS/i386/repodata/primary.xml.gz: [Errno -3] Error performing checksum  
Trying other mirror.  
Error: failure: repodata/primary.xml.gz from git: [Errno 256] No more mirrors to try.  

Any suggestions as to a solution, or details why the kernel.org repo has this issue?

(Sorry I can't include more links to my references, but I don't have the reputation for that yet.)

share|improve this question

1 Answer 1

I found myself in the same situation and solved with the following:

  1. Temporarily disable the git repo
  2. yum install python-hashlib
  3. Verified my yum version (I had 3.2.22)
  4. yum clean all
  5. yum repolist

I then tried to update git, but there were a lot of dependencies failing. I stumbled upon this and was able to install git:

http://www.webtatic.com/blog/2009/09/git-on-centos-5/

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.