Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just installed IE9 to give it a test run. One of the first sites I've visited - http://fundcentre.newireland.ie - causes IE9 to crash, close the tab, and attempt to reopen it, thus repeating the cycle endlessly.

Is this happening for anyone else with IE9 also? Would anyone be able to shed light on why this is happening?

just noticed: it seems to happen only with IE Dev Toolbar.

share|improve this question
6  
Because IE9 is beta would be my guess. –  joeqwerty Oct 23 '10 at 12:42
add comment

3 Answers

Don't forget that, as of this writing (23rd Oct 2010), IE9 is still a Beta broswer so there will be some issues with it.

Is there a "report a problem page" for IE9 on the Microsoft site? If so tell them that the site fails - giving as much information as you can - and go back to your current browser.

Hopefully, this sort of problem should be sorted out by the time the browser is fully released.

share|improve this answer
    
... thanks for the advice, but I think I'll stick with Firefox :-) –  DaveDev Oct 23 '10 at 14:14
    
@DaveDev - I shouldn't have assumed which browser you were using, I'l update the answer. –  ChrisF Oct 23 '10 at 14:16
add comment

Not a reason to crash, but the HTML that site gives you is bad. Like halfway the document, in the middle of a table, it suddenly gets one a new HTML document:

<table align="center" style="margin: 0 auto;">
  <tr>
    <td>
      <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
         "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
      <html xmlns="http://www.w3.org/1999/xhtml">
        <head profile="http://www.w3.org/2005/10/profile">
          <meta http-equiv="Content-Type" content="text/html; 
            charset=iso-8859-1" />

So, if this causes IE9 to crash, then be happy you won't see this in many other sites (if any). Apart from reporting this to Microsoft (they'll be thankful), reporting to the webmaster of that site will be appreciated too!

As for the endless loop: maybe temporarily disabling your network/internet connection stops IE from doing this?

share|improve this answer
    
(I already notified the folks at newireland.ie about this question.) –  Arjan Oct 23 '10 at 13:58
    
Looks like a missing iframe. –  Broam Oct 23 '10 at 16:24
    
@Broam, that would be <iframe src="..."> not <iframe>...</iframe>, so would not insert the content this way. Maybe some server side include though? –  Arjan Oct 23 '10 at 16:59
add comment

You can try to see if this happens when you use compatibility mode or try the platform preview(7 while I am writing this answer) if you want to see if this was solved.

Report to Microsoft and the site owners is always a good thing to make this resolve faster.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.