Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I wrote a simple Windows program and put it in my "Start up" folder on the start menu.

But when Windows starts up, it always launches it twice. I get two instances of my program and I always have to manually exit one of them.

It is only in the All Users start up profile, not any of the other User profiles. I haven't touched the registry at all. If I remove the program from "Start up", then it doesn't start at all.

This actually happens on both 7 and xp for me for this particular program.

share|improve this question

3 Answers 3

Go to the run dialog box and type in msconfig.

A box like the one below should come up:

enter image description here

Have a look on the startup tab and uncheck the entries for the application that is launching twice.

share|improve this answer
    
Yes, you're right. It does appear there twice. When I uncheck one of them, then close the dialog, then reopen it, the duplicate disappears, but the program I want to start up is unchecked. When I check it again, then close/reopen the dialog, the item is duplicated again, both times checked. I am thinking is it wrong to just copy something into the Start Up folder manually? Because that is how I added it to Start Up to begin with.. –  bobobobo Aug 9 '09 at 23:01
    
Yes, by adding it to the startup folder, it should launch when you log in. What may be an idea, is to uncheck the entries in 'msconfig' for the application, add the application to the startup folder, but also check in the preferences of the application whether it is set to launch on login, or something similar. Would you be able to tell me what the problem application is? –  Alexis Hirst Aug 10 '09 at 10:01
    
Alexis, it's a program he wrote himself. –  Travis Aug 10 '09 at 15:25

Check that the program isn't installed in "All Users\Starup" as well as "Your Username\Startup"

This happened to me once when I was fiddling with the start menu.

share|improve this answer
    
:) Yes I double-checked this before posting. –  bobobobo Aug 9 '09 at 22:59
    
That's cool - if I could have a dime for each problem I've solved where someone said "I checked this or that setting..." I could retire. :) –  EvilChookie Aug 10 '09 at 1:37

You Could make try making this registry file (remove the shortcut from all users start-up first)

----------------------------------------start copy

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run]
"{Software Name}"="\"C:\\Program Files\\{Install Folder}\\{Application Name.exe}\""

end copy-----------------------------------------

Change the {folder and file names} to what ever you need to start, removing the curvy brackets.

Save it as a .txt file then change the extension to .reg

Run the file and see if it corrects the issue

If not you can always remove the entry by creating a .reg file with this line (remeber to change the {software Name} to what every you changed the first one to.

------------------------start copy

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run]
"{Software Name}"=""

end copy---------------------------

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.