Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When playing .AVI files on VLC (1.1.3 / Mac OS X 10.6.2) I often get intermittent distortion in the video. It breaks up into squares and bits of previous video are mixed with the current video.

It's hard to describe but here are three frames showing it happening:

enter image description here

enter image description here

enter image description here

And importantly, this isn't corruption of the file itself because I can rewind, play the same sequence again and not get the distortion.

What settings can I change to stop this happening, or minimize it?

EDIT: lots of people saying to try other players, which is fine. But, what's interesting is, I was assuming there would be a solution where I would stick with VLC and give it number one priority over other processes, or let it use more RAM or something? I was assuming there was a solution where I stuck with VLC but told my computer, or the application, that watching video was very important to me.

share|improve this question

4 Answers 4

What is the configuration of your Mac (CPU, RAM, video card…)? If you try playing the file(s) in question in other players it can help diagnose the problem (note that QuickTime requires Perian to play AVI files). If all players have the same problem then it's probably file corruption, low bit rate, low RAM, under powered video card, background process's, or something else of that nature. If other players have no problem with the file then it's likely a setting in VLC or just VLC itself.

You could control how much RAM an application used in OS 9 but OS X handles memory usage automatically. If you would like to renice VLC, atMonitor gives you a gui interface to do so. Renice can also be done from the CL if you know the commands. But that's not a way of dealing with blocking that I'm familiar with, it sounds more like a decoding issue.

share|improve this answer

I've never had good luck with VLC on OS X. I would suggest trying Movist using the ffmpeg decoder, it works very well for me on my G5 DP.

share|improve this answer
    
I will check it out, thank you. –  Ambrose Oct 24 '10 at 22:54

First, try updating to VLC 1.1.4.

Second, what kind of video file is it?

share|improve this answer
    
I did "check for update" and VLC told me it was up to date! But I will, thank you. The files where this happens are normally DivX files. It doesn't happen when VLC plays DVDs. –  Ambrose Oct 24 '10 at 22:53
    
High Def DivX? I have the same trouble on windows. –  Force Flow Oct 24 '10 at 23:29
    
You could try the official DivX Player (there's a version for OS X): divx.com/en/software/mac –  Force Flow Oct 24 '10 at 23:35
    
Yes, also has it played with Quicktime? –  Muhammad Usman Oct 25 '10 at 0:15
    
"High Def DivX?" No, not at all. That video you're seeing the screenshot from is very low resolution. –  Ambrose Oct 25 '10 at 2:06

Seems that codec doesn't have enough time to read all needed data to decode. Is the avi file placed on slow/network drive? Do you have heavy background processes running?

share|improve this answer
    
No major background processes, no, except for a bit of torrenting. And it's off an external USB 2 drive, so that might be a factor. I'll test by running off the local HD. –  Ambrose Oct 24 '10 at 22:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.