Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

One of my network shares is down, which isn't a big deal, but now my Ubuntu instance fails to boot properly. On boot it will display the screen giving me the option to skip the mount, or do a manual mount, however it won't respond to keyboard input at this point. Pressing escape (I believe it is escape) gets away from the splash screen and shows the boot log, ctrl-alt-del works, but nothing else.

The last status message is "mountall: mount //mydrive/ failed with status code 1" yet I can't bring up command prompt or anything.

How do I get to the prompt so I can edit fstab and delete the share? I've tried to ssh and vnc into the machine, but it doesn't respond to the requests. I can ping it and see the shared folders on the machine, so some modules have loaded.

Any ideas?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Pass init=/bin/bash on the kernel command line to boot directly into a shell, with no service running whatsoever. With the default bootloader settings, you may need to press Shift to make the boot menu appear; press Shift as soon as the BIOS has initialized the keyboard and hold it until the boot menu appears. At the menu, edit the line beginning with kernel to add init=/bin/bash at the end, then boot.

Once you have the bash prompt, run the following commands:

mount /proc
mount -o remount,rw /
vi /etc/fstab  # or whatever your favorite editor is
mount -o remount,ro /
reboot -f

(By the way, not being able to skip the network mount sounds like a bug.)

share|improve this answer
    
Worked beautifully, nice to know how to get bash in case something like this happens again. Thanks! –  chum of chance Oct 26 '10 at 2:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.