Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running Windows 7 x64 RTM on a Dell Latitude D520 w/ 4gb memory. The system control panel reports:

System type: 64-bit Operating System
Installed memory: 4.00 GB (3.24 usable)

Why isn't all the memory usable? Since I'm running 64-bit, is this a dell limitation?


Edit:

It's given me more questions:

  1. If the system reports that I can use 3.24gb, does that mean that .76gb is being used by the video card? That seems like a lot, and the specs on this page state it will use up to 128mb)
  2. If .76gb isn't being used by video, is it being wasted?
  3. Does running 64-bit windows help me at all? If not, are there other advantages to 64-bit windows?
share|improve this question
    
@Joey, Vista was no better at the memory usage it was just reported differently in the GUI –  edusysadmin Feb 12 '11 at 16:20
    
@edu: Know that by now. Didn't back then, though. –  Joey Feb 12 '11 at 16:52

5 Answers 5

up vote 5 down vote accepted

Either you do what Post#1 suggests, or your motherboard simply doesn't support the memory address mapping, which means: No 4GB for you with this hardware.

share|improve this answer
1  
What is Post#1? Do you mean John T's answer? –  Tom Wijsman Feb 25 '11 at 23:03

There are 2 probable reasons for this.

  • You need to turn on Memory Remapping in your BIOS
  • Your video card may be sharing internal memory.

It is usually the latter that is the case. This was one of the planned features of Windows 7, you can read up on it here.

share|improve this answer
    
Flashing bios now to latest...will poke around in bios on restart for that option. Be back in a minute... –  Michael Haren Aug 9 '09 at 17:57
    
Updating the BIOS didn't help. I didn't see any memory related settings in there, either. Though, it did have this message: "Due to the amount of memory being assigned for system use, memory available is less than memory installed." –  Michael Haren Aug 9 '09 at 18:07
    
that would indicate it is sharing memory... probably with your video card. –  John T Aug 9 '09 at 18:11
3  
By default your chipset has memory remap turned of to be compatible with 32-bit systems. This causes pci cards/gfx cards/io cards and everything to be mapped into memory below the 4GB limit. This happens before Windows comes into the picture and there's nothing Windows can do about it. To be able to use your memory you need a 64-bit OS and memory remap turned on. –  Pär Björklund Aug 9 '09 at 20:33
1  
Forgot to add, if you cannot find this in your BIOS you should contact your hardware vendor Vista SP1 introduced a new "feature" that displays all installed memory instead of all memory available to Windows to avoid these kind of questions. This means that Vista pre-sp1 displays 2.93GB and Vista post-sp1 displays 4GB. The end result is the same, all that changes are the cosmetics. –  Pär Björklund Aug 9 '09 at 20:35

It may be a windows limitation, too. However there aren't usually on pre-release version IIRC.

share|improve this answer
    
I'm running RTM, Ultimate (from MSDN) –  Michael Haren Aug 9 '09 at 18:06

I have a D520, and I see about the same amount of loss. I'm running Linux with a kernel that has PAE enabled. I'd always assumed that the missing memory was being used for the onboard video chipset.

share|improve this answer

It's a limitation of your chipset/video card/device driver. Windows(or in some cases, BIOS) maps memory to the video card to use cause it doesn't have its own memory. Windows can't just use it whenever it wants cause, it would be a violation of sound principles. Microsoft had thought about mapping and remapping that memory above the 4GB line based on usage. The problem thought was this would cause HUGE instability on consumer systems. Notice that Windows Server does NOT suffer from the 4GB limit, even on x86 machines...

http://msdn.microsoft.com/en-us/library/aa366778(v=vs.85).aspx#physical_memory_limits_windows_server_2003

The reason was, again, device drivers. The server market tends to have a smaller market of device driver and DD developers, thus it was possible to test and support larger address spaces. On the consumer side, this is a nightmare. Technically, XP SP2 and above x86 OSes CAN use memory address over 4GB. Not all device drivers though supported that, since going over 4GB meant your pointers are longer. Thus DDs would often spit out an error and thus cause blue screen or not even boot.

Another consequence of remapping the video memory is that the video card is latency sensitive. Remapping the memory back to the card involves the following:

  1. Moving whatever was there to the page file. . . (spin spin)
  2. Writing in the OS memory map database where you put the file
  3. If it needs contagious memory . . . repeat 1 and 2
  4. The video card then has to wait for the memory to be allocated. (twiddle thumbs)
  5. Loading up textures for the video card. (spin spin)
  6. Writing in the memory map database where you put the textures
  7. Then constantly poll the graphics card, "Are you done yet? Are you done yet?? Yeah! Yeah!? Cause Johnny boy in the taskbar REALLY REALLY needs to go BAD!!"
  8. The graphics card then decides, based on some algorithm, what it should and should not keep.
  9. Then tell the OS what part of the memory it is not using.
  10. All this in time to give you 60 frames a second (well not technically, but you see the point)

This will also affect all the other drivers that the OS manages that are latency sensitive ie audio driver (skip skip) and network drivers (Hey, how did that guy teleport through the door!?)

How can you solve this? By promoting a higher quality of device driver developers. They are HIGHLY underrated and unappreciated. Ideas include sending your local DD developers care packages, Lego Robotics kits, big monitors, and of course, women.

share|improve this answer
    
x64 pointers ARE longer, none of this applies to a 64-bit OS. –  Ben Voigt Jul 1 '11 at 2:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.