Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Windows has this nifty little shortcut for running commands. Press Windows + r.

Problem is, is there an easy way to have the commands I run in that dialog to prompt for a UAC credentials dialog and get consent from a admin user.

Right now, I'm trying to run this command in the Run dialog runas /user:admin "regedit.exe"

It works when I run this though: runas /user:admin "cmd"

share|improve this question

8 Answers 8

up vote 15 down vote accepted

I have the exact same problem. The Ctrl+Shift+Enter solution only works if you use the not-as-reliable start menu run box - but for the Win+R run box you are out of luck. The closest thing to a solution I have found is to manually set application properties to 'Run as Administrator' under the program compatibility tab.

For system utilities such as cmd.exe, you can put a shortcut in your User folder (C:\Users\%USERNAME%) and set 'Run as Admin' under shortcut advanced settings. See http://helpdeskgeek.com/windows-7/command-prompt-admin-rights-windows-7/ for detailed instructions. (To run the short cut you have to type the whole file name, e.g. cmd.lnk)

share|improve this answer
    
Yea, I've noticed that that too. Ctrl+Shift+Enter never actually works for me outside of the Start Menu and even then, its not because its in the search box, but because by default it selects the first thing on the list. –  wag2639 Oct 28 '10 at 6:10
1  
Unfortunately I too can confirm this annoying limitation. I don’t like typing things into the Start menu because it takes much longer to use than the Run dialog because the run dialog takes raw input, but the Start menu searches for matching programs, which can take a while if you have a long path. Why oh why doesn’t Ctrl+Shift work with the Run dialog? Even getting an elevated Run dialog is a chore, the fastest way being via an elevated Task Manager. :-( –  Synetech Mar 3 '11 at 20:08

This is how you run executable files as administrator from a Windows Run dialog:

RunAs.exe /user:Administrator "regedit.exe"

You must use RunAs.exe instead of runas.

share|improve this answer
    
ALL CAPS is considered offensive! Please don't post with ALL CAPS again. –  Simon Apr 10 '13 at 5:33
    
Thanks "The Guy" ! –  Marin May 14 '13 at 14:08
    
Windows filenames are case-insensitive, and PATHEXT includes ".exe", so RunAs.exe and runas resolve to precisely the same command. –  Steve Howard Sep 6 '13 at 23:31

On Windows 8/Server 2012, if you want to run cmd as an administrator you can just use Win + X. Then in the popup menu you can run cmd through the Command Prompt (Admin) option.

See the screenshot: screenshot

share|improve this answer
    
I tried Win+X in a Win7 VM, and it did nothing. Win+R brings up the Run dialog, so the Windows key works fine. Is this for some other version of Windows, or is it provided by some additional utility or controlled by some setting? –  Michael Kjörling May 10 '13 at 20:17
1  
Like he said, Windows 8 and Server 2012. The Win+X shortcut is sort of a consolation for people that missed the Start menu. –  Steve Howard Sep 6 '13 at 23:30

Press Control+Shift before running a program and it'll run elevated.

share|improve this answer
    
Does not work to me, not with the run dialog. –  Tomáš Zato Dec 30 '13 at 14:30

just press Win and then enter regedit. windows7 will provide you with some suggestions, rightclick onto regedit.exe and pick "run as administrator".

share|improve this answer

Take a look at Elevation PowerToys for Windows Vista. It allows you to run applications as administrator by simply running "elevate [command]"

share|improve this answer

CMD works just like the run command, if you pin it to the taskbar you can Ctrl+Shift+Click it.

share|improve this answer

An alternative is to turn UAC off completely and always run all programs as administrator. It's maybe not recommended but believe me, it's a relief.

In Vista you could turn it off in the control panel, in Windows 7 you must modify the registry (Note: This is NOT the same as the no nags setting which only hides UAC without disabling it):

Windows Registry Editor Version 5.00 
;Disable UAC
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System]
"EnableLUA"=dword:00000000

A reboot is required after changing this.

Also be warned that this also disables VirtualStore (the redirection of reads and writes to/from the program files folder). To keep rogue programs intact you need to properly merge the .../AppData/Local/VirtualStore with your program files folders.

share|improve this answer
1  
UAC should not be disabled. Its a very useful, though poorly implemented UX-wise, security feature of the OS. –  wag2639 Nov 19 '12 at 5:20
1  
Why all the downvotes? This is actually a working solution. When I work, I need admin right very often and I know what I am doing. I don't want UAC to get in my way all the time and I don't want to work around the Run dialog limitations every time. This is not a viable solution for a home computer, but definitely has its appliances. –  Jakub Januszkiewicz Mar 19 '13 at 13:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.