Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Wake-on-lan configured on my Windows XP machine so that the computer will wake up from Standby. Waking the computer from Standby via network traffic seems to work a certain number of times, say 4 or 5, then it stops working. If I restart the computer it seems to reset this behavior so that I can use WOL a few more times before it starts working. I use the command "wol" on my other, Linux machine with the appropriate IP address and MAC address of the card.

I looked at the network card to see if it had different lights when WOL worked and when it didn't. When it has a solid amber light where the ethernet cable connects, WOL seems to work. When it has a flashing amber light, WOL does not. It seems that the system seems to almost "shut off" the card when it falls to sleep, but I don't know if this is a function of time or number of standby/wakeups.

I have a 3Com 3c920 network card. If I look at the properties in Device Manager, I have "Allow this Device to bring the Computer out of Standby" checked. In the Advanced tab I have anything related to RWU (Remote Wake Up) enabled. I also believe I have the appropriate settings in BIOS related to Remote Wake-Up and I have tried both S1 and S3 power configurations in the BIOS. Intuitively, I would think I would uncheck "Allow the Computer to turn off this device to save power", but doing so disables the "Allow this Device to bring the Computer out of Standby" option.

Does anyone know what is happening here or if there is a way to fix it? I have an integrated network card; would getting one that goes into a slot be better?

I am running Windows XP on a Dell Optiplex GX240 with a 3Com 3c920 network card.

share|improve this question
    
I have this same problem with another machine, a Dell Latitude C810 Laptop. –  Chance Feb 7 '11 at 22:38
add comment

2 Answers 2

Chances are you are sending to an ip address which is not the broadcast address for the local network. What happens is that when you turn your machine off it loses the ip address but your switch/hub and other machines will keep this information in it's arp cache. When this cache expires you will not be able to WoL unless you use the broadcast address.

share|improve this answer
    
So, if I had a local address of 172.17.0.2 (the machine to wake) I would send out 172.17.0.255? –  Chance Oct 25 '10 at 19:48
    
All depends on the subnet mask but if it was 255.255.255.0 then yes 172.17.0.255 would be the broadcast address. –  depicus Oct 25 '10 at 20:34
    
Man, I was hoping that was it, but it does not seem to be the case. Even with the 172.17.0.255 address it didn't seem to work. I decided to abandon WOL and just schedule a shutdown around midnight and boot back up in the morning to save power. Thanks though. –  Chance Oct 26 '10 at 19:09
add comment

Some things you could try :

  1. Assign the computer a static IP address
  2. Check if a BIOS update is available (take care!)
  3. Update manually router's ARP table if you can telnet to it using arpadd. See :
    SpeedTouch Configuration: Wake up on LAN.
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.