Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I tried to make notepad++ the default program I used this .bat:

rem If you are using Vista x32 version, then edit this file first by adding “rem ” in front of every line that contains the phrase “syswow64?. Then run the script again.
@echo off

takeown /f C:\Windows\syswow64\notepad.exe
cacls C:\Windows\syswow64\notepad.exe /G Administrators:F

takeown /f C:\Windows\system32\notepad.exe
cacls C:\Windows\system32\notepad.exe /G Administrators:F

takeown /f C:\Windows\notepad.exe
cacls C:\Windows\notepad.exe /G Administrators:F

copy C:\Windows\syswow64\notepad.exe C:\Windows\syswow64\notepad.exe.backup
copy C:\Windows\system32\notepad.exe C:\Windows\system32\notepad.exe.backup
copy C:\Windows\notepad.exe C:\Windows\notepad.exe.backup

copy C:\Program Files (x86)\Notepad++\notepad++.exe C:\Windows\syswow64\notepad.exe
copy C:\Program Files (x86)\Notepad++\notepad++.exe C:\Windows\system32\notepad.exe
copy C:\Program Files (x86)\Notepad++\notepad++.exe C:\Windows\notepad.exe
@echo on

This seemed to work it copied the files fine but now if I try to edit a .txt this happens:

enter image description here

If I click on the notepad++ or the modified notepad.exe it opens fine. How can I get this working?

share|improve this question
+1. I'm on xp and the answer from @st worked. Thanks, – Xavierjazz Oct 26 '10 at 5:06
up vote 0 down vote accepted

Hmm, that may have worked but I found I program that installs and makes notepad++ the default all in one shot. It worked great. And I haven't have the langs trouble since, unfortunately I do not remember where I downloaded it from but I do have a drop IO link I just made...

Hope its not against the rules to post DL links if so I apologize in advance.

share|improve this answer
Just so everyone knows...I couldn't remember my log in info so I singed in as my alias Josh Goodman. LOL – TackleBox Nov 20 '10 at 17:52


1.Open your “Notepad++” installation folder (right click on the shortcut icon, “Open File Location”)

2.Rename / Delete “langs.xml” to a backup (langs.xml.bak or something to that affect)

3.Copy “langs.model.xml”

4.Rename the new “langs.model.xml” to “langs.xml”

5.Restart Notepad++

share|improve this answer
+1. Thanks very much for this. I'm on xp, but I followed your directions and it worked. One small detail, Step 4 should be, "Paste the copied file". Then so on. Regards, – Xavierjazz Oct 26 '10 at 5:03
I did that but still same thing notepad++ will open from both of the exe files (notepad++.exe and the notepad++.exe that is now called notepad.exe in c:\windows) and shortcuts I can even drop a .txt or .bat file onto the desktop shortcut to notepad++ and it works fine but if I right click on a *.txt it gives the error.... (win7) – TackleBox Oct 26 '10 at 6:46

Are you running Notepad++ with Administrator privileges? Check by right-clicking the notepad++.exe -> Properties -> Compatibility -> Make sure the "Run as Administrator" box is unticked and the program is not run in compatibility mode.

And where did you get the batch script from?

share|improve this answer
I really don't remember where I got the script for. I apologize, next time I post something I didn't wright I will be sure to include such information. – TackleBox Oct 31 '10 at 2:07

I had the same issue form months. I wanted to use notepad++ but... langs.xml kept becoming corrupted every now and then. The solution that worked at the end was to do to the application folder and make the file read-only.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.