Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed emacs on Ubuntu 10.10 using sudo apt-get install emacs-snapshot-gtk

I prefer my emacs in the terminal and everytime I emacs something, it pops up in some fancy GUI window. How do I go old-school?

Thanks.

share|improve this question
up vote 30 down vote accepted

Start it with:

emacs -nw

If you're using bash you can set an alias by adding to your ~/.bashrc:

alias emacs='emacs -nw'
share|improve this answer
    
Useful idea, but then you can't just $ emacs myfile - it will append -nw as bytes to the opened file. – Luka Ramishvili Nov 27 '12 at 18:28
1  
I don't think so, with that alias emacs myfile is the same as emacs -nw myfile and that's perfectly legit since -nw gets parsed as an option. – cYrus Nov 27 '12 at 18:53
    
"Perfectly legit" seems to be very individual, since I'm very used to the fact that when I open a file, the string '>1;3201;0c' won't be prepended to the file's head and the buffer won't be marked as modified. It may work for you, but not for me, sorry. – Luka Ramishvili Dec 1 '12 at 17:56
    
emacs -nw then C-x C-f works perfectly, but why emacs -nw myfile doesn't work, I don't know. – Luka Ramishvili Dec 1 '12 at 18:26

What about installing the no X window system version:

apt-get install emacs-snapshot-nox
share|improve this answer
    
It is emacs24-nox for Ubuntu 14.04. Just for the reference. – Dmitry Volosnykh Mar 14 at 12:07

There's another solution to "make emacs open files quickly" - just start emacs with

emacs -f server-start

and then open every file with

emacsclient -n <file>

If you have emacs client running - this command opens text file in a moment!

To make this solution more usable you can

  1. make emacs server starting at start-up
  2. put alias ec='emacsclient -n' in ~/.bashrc
  3. If you use Krusader - you can set there emacsclient -n as a default notepad - so it opens a file with F4.
share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .