Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I run Ubuntu 10.04 as my primary OS. When I try to go to the Python docs site http://docs.python.org/, I find it times out. At least one other unrelated site also acts the same but I won't mention it here due to its secure nature. In other words, it's not specific to the Python site.

However, from a VM on that box, running XP, it works fine. So I'm pretty certain the network path is the same.

A traceroute from the VM succeeds:

  1     1 ms     1 ms     1 ms  192.168.0.1
  2     3 ms     1 ms     1 ms  mygateway1.ar7 [10.1.1.1]
  3    23 ms    23 ms    23 ms  per22.ba.optusnet.com.au [198.142.131.23]
  4    23 ms    23 ms    91 ms  per1-ge0-0-447.gw.optusnet.com.au [198.142.49.225]
  5    81 ms    81 ms    81 ms  mas3-ge2-0-0-811.gw.optusnet.com.au [211.29.155.11]
  6   251 ms   235 ms   235 ms  203.208.148.97
  7   233 ms   238 ms   231 ms  10gigabitethernet1-3.core1.lax1.he.net [206.223.123.37]
  8   302 ms   298 ms   300 ms  10gigabitethernet4-3.core1.nyc4.he.net [72.52.92.225]
  9   385 ms   374 ms   375 ms  10gigabitethernet3-1.core1.ams1.he.net [216.66.24.154]
 10   384 ms   385 ms   566 ms  xs4all.10gigabitethernet3-3.core1.ams1.he.net [216.66.84.58]
 11   384 ms   392 ms   384 ms  0.so-1-0-0.xr4.1d12.xs4all.net [194.109.5.1]
 12   380 ms   381 ms   380 ms  te5-4.swcolo2.3d12.xs4all.net [194.109.12.34]
 13   385 ms   384 ms   384 ms  dinsdale.python.org [82.94.164.162]

Trace complete.

A traceroute from Ubuntu does not:

 1  192.168.0.1 (192.168.0.1)  1.556 ms  2.072 ms  2.572 ms
 2  mygateway1.ar7 (10.1.1.1)  9.789 ms  9.942 ms  10.055 ms
 3  per22.ba.optusnet.com.au (198.142.131.23)  26.961 ms  29.120 ms  30.295 ms
 4  per1-ge0-0-447.gw.optusnet.com.au (198.142.49.225)  31.657 ms  33.243 ms  35.076 ms
 5  mas3-ge2-0-0-811.gw.optusnet.com.au (211.29.155.11)  94.694 ms  96.076 ms  97.724 ms
 6  203.208.192.169 (203.208.192.169)  247.401 ms  233.327 ms  230.700 ms
 7  xe-3-2-0.lax20.ip4.tinet.net (77.67.79.9)  232.466 ms  233.434 ms  234.605 ms
 8  xe-10-0-0.lon21.ip4.tinet.net (89.149.184.249)  378.506 ms  379.635 ms  381.975 ms
 9  * * *
10  * * *
 :
29  * * *
30  * * *

Now they're the same up to step 6, and I'm not sure if the path being taken from there is the problem. My question is why does it take different paths? My Ubuntu box is 192.168.0.101 and my VM is the same but ending in .102.

The box is connected to a wireless access point (through a cable connection) which is, in turn, attached to the ADSL modem. A laptop elsewhere in the house, using the wireless access, also has no trouble.

What could be causing this behaviour for the primary box?

share|improve this question
    
Welcome to Open Source! –  ta.speot.is Oct 30 '10 at 2:22

3 Answers 3

up vote 2 down vote accepted
+200

Are you using the same DNS server and does the website resolve to the same IP address on both operating systems? Also if you do a traceroute to 82.94.164.162 from Ubuntu does it still go wrong?

The most likely cause is stale dns which means that Ubuntu is trying to go to the wrong ip address. If it definitely is going to the same address, then in would appear to be a problem outside your control, probably at the 203.208.192.169 which would appear to belong to Singapore Telecommunications Limited. 203.208.148.97 is also owned by them but that appears to work

You could try emailing them with the technical details.

share|improve this answer

First how many ethernet device you have?
Did you tweaked the firewall (iptables) or the /etc/hosts file?
Can you try disabling the firewall to see?
How you VM network is done? By NAT or Bridged? If Bridged to which device? You have this behaviour so far only on this particular website?
Did you tried resetting/reconfiguring:

  • Network (including checking at /etc/resolv.conf)
  • Ethernet configuration

Sorry lots of questions ;-)

share|improve this answer
    
No probs. (1) No tweaking, standard 10.04 install, whatever Ubuntu put on itself. (2) How do I disable the firewall? I assume you mean the Ubuntu one, not any I have on the wireless router or modem, yes? (3) VM is bridged. Both Ubuntu machine and Windows VM (and wireless laptop) get IPs from wireless router. Router itself connects to modem. (4) Two websites: docs.python.org and eztv.it. (5) Do you mean via ifconfig down/up? Or rebooting the modem/router? The first shouldn't help since the machine cycles power daily. Haven't tried the latter. –  paxdiablo Oct 28 '10 at 12:30
    
Oops, missed first question: One physical ethernet device, on motherboard. Three or four virtual ones due to the way VMWare works (VMNet8 and some other one, plus eth0 and loopback). –  paxdiablo Oct 28 '10 at 12:33
    
Sorry I'm not used to ubuntu but thanks for the replies. So first since you have only one real ethernet device and the VM works, it's not you eth0 card nor your router/modem. The weird part is that you have bridged network since it would behave the same both on OS and VM. To start/stop the Firewall: looking here wiki.ubuntu.com/UncomplicatedFirewall it seems: sudo ufw status (if it's already disabled don't do anything otherwise: sudo ufw enable) –  Warnaud Oct 28 '10 at 12:48
    
No characters left :P Regarding the network configuration, can you manually try 'ip addr flush eth0'(as seen here: help.ubuntu.com/10.04/serverguide/C/network-configuration.html) then ask for an ip whether by restarting the network service or 'sudo dhcpcd eth0' and last thing, check your /etc/resolv.conf and /etc/hosts and /etc/network/interfaces (you can maybe pastebin them) –  Warnaud Oct 28 '10 at 12:55

The thread Frequent internet time out announces the following solution for timeouts:

arp -i eth0 -s IP xxx.xxx.xxx HW address xxxx: xxxx: xxxx

As I am not an Ubuntu person, you will have to validate this answer yourself.

Another thread, Internet connections only to some sites - others timeout, advices to add the following two lines to vi /etc/sysctl.conf followed by sysctl -p:

net.ipv4.tcp_wmem = 4096 16384 131072
net.ipv4.tcp_rmem = 4096 87380 174760

And also advices:

echo 0 > /proc/sys/net/ipv4/tcp_window_scaling

This is better explained in: TCP Window Scaling and kernel 2.6.17+.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.