Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using a software called Notational Velocity for taking notes on my mac. It's great, there's just one shortcut thing I'd like to fix: the software indents with tab key like any other text editor, but when I want to "unindent" (move text to the left) it doesn't work like it does in all other editors (with shift+tab).

I tried to change this from my system preferences but noted that when I try to assing a shortcut with tab key in it, it simply changes focus out of the field I'm typing in, like the tab key does. So, how can I add a new shortcut shift+tab in mac's system preferences? I tried to google it but found no answers. Thanks in advance for help!

With best regards, Juho

share|improve this question
NV does indent/unindent with Cmd-] / Cmd-[ (look in the Format menu). – Daniel Beck Oct 26 '10 at 7:40
Yeah I know, I just wanted it to unindent with that specific command since I use it in various other applications and thus try it automatically when trying to unindent. Also, I have a Finnish keyboard that does not have the [-key so I had to change the shortcut anyway. It's now cmd-<, I'll probably settle for that. – Kusti Oct 27 '10 at 12:24
up vote 0 down vote accepted

Only Tab key (with/without Shift) is probably too dangerous or interferes with focus control, so they don't support it.

I tried editing the .plist preferences files myself, but even though the menu shows the correct shortcut, its use does not perform the menu command, but changes focus.

Shift Tab

Your options now are to dig into NV source code, or live with indent/unindent using Cmd-] / Cmd-[.

share|improve this answer
Hmph, irritating. Understandable though, but seems silly considering that numerous other applications use exactly that shortcut. Thanks anyway. – Kusti Oct 27 '10 at 12:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .