Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Currently the terminal prompt looks like this:

[karlis@karlis-desktop current_folder]$

How can I minimize the prompt, so that it only shows $ or # without extra info in square brackets?

I checked the preferences for the default Gnome-Terminal and Terminator - there are no settings for this. It is pretty hard to use terminal when working in directories with long names.

share|improve this question
up vote 5 down vote accepted

Modify $PS1.

share|improve this answer
    
Thank you! Very useful link :) – skazhy Oct 26 '10 at 8:55
1  
The only thing I would recommend is to use tput instead of the raw escape sequences. You can do fancier things that way as well. – Ignacio Vazquez-Abrams Oct 26 '10 at 8:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .