Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

How I disable SSL certificate error when CN does not match DNS name in Chrome?

In IE, this is done by Tools -> Internet Options -> Advanced (tab) -> Scroll down to section "Security" -> checkbox: "Warn if adresses in certificates does not match".

enter image description here

I get that pesky warning for every SSL site im visiting, my internet bank, logging in to gmail, visiting forums based on SSL and such. Every SSL site throws this warning. I just want to get rid of the warning.

share|improve this question
4  
Ummm... you're not concerned about this? If the name on the certificate doesn't match the domain you're visiting, you're at risk that your SSL communication is being decrypted by somebody else. I think you should get to the root of this problem rather than hiding the warning. –  Doug Harris Oct 26 '10 at 14:33
1  
If this is happening for you on every site, you may have a serious problem with your certificate chain, or you could even be the victim of a man-in-the-middle attack. Don't just disable the warnings without investigating. –  phoebus Oct 26 '10 at 15:32
    
I know how to solve the problem in IE. Importing the root certificate in the root store, and then unchecking "Warn if adresses in certificates does not match", solves the problem for every SSL site. What im asking for, is how to disable the hostname check in Chrome. –  sebastian nielsen Oct 26 '10 at 17:33
    
go to a coffee shop, go to eff.org. Chrome should show you a green lock on this page: eff.org/observatory Read it. –  chiggsy Nov 3 '10 at 5:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.