Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm running Ubuntu 10.04 on two separate machines on a network (Ubuntu machine A and B). I am running some tests with temp files for some other software, installed on Ubuntu machine A. The software uses a temp directory in /tmp/<usrname>/temp_dir. My goal is to mount an external hard drive attached to Ubuntu machine B on Ubuntu machine A under /tmp/<username>/temp_dir so the external hard drive acts as this temp directory for said software on Ubuntu machine A. There happens to be a bug such that when this occurs in the wild the software can't save the temp backup file (this was reported from a user).

My problem is I can't even get the external hard drive mounted where I want it. How do I do this?

Please note, using the same commands, I can mount network shares just fine, according to this post.

share|improve this question
up vote 2 down vote accepted

I ended up going through both machines and updating all my samba packages. I thought I had all the right ones installed but perhaps not. I installed server/client packages on both machines and then tried again. This time I got a useful error: no IP address found. Even though I was using the server name on my network, samba didn't like this. I ended up using this command:

sudo mount -t cifs -o username=<username> // /tmp/<username>/temp_dir/

and after entering the password at the prompt, the mount took. I tested the software and everything seems to be in order.

I think I must have installed some utility package that was needed for mounting Linux shares. While this seems absolutely ridiculous to me that I was able to mount Windows shares but not Linux shares with the old configuration, I'm happy it worked. I'm still learning how to use these packages with the package manager. My assumption that installing a package will just magically work is becoming very tiresome.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .