Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Chrome 7 keeps showing a dialog saying: 514 Authentication Required when I use TOR.

How I solve this?

share|improve this question
Did you follow these directions?… – Moab Oct 26 '10 at 21:45
thanks, but it doesn't solve my problem. Chrome shows me the following message: 514 Authentication Required, when using Proxy Switchy! extension with Tor. Help ME! – Junior Oct 27 '10 at 18:30

I found this to work: I have the Tor Bundle installed which is Firefox 7 + Tor. To make Chrome work with it I did this on Windows:

I created a shortcut to Chrome, right-clicked on the shortcut > Properties. There on the Shortcut tab in the Target field is the address of the executable, like:


Add the proxy details after it so it looks like:

C:\Chrome\chrome.exe --proxy-server=";socks=;sock4=;sock5=" --incognito

This will set it to use SOCKS proxy on localhost ( on port 9051 (not sure where this is set, Tor's settings seem to use that), and is just the address it will open with.

share|improve this answer

You tried to use Tor as a http proxy. Tor isn't a http proxy!

2 solutions :

1 (the best) - install a private web proxy likes polipo ou privproxy, proxy switchy will control this setup (chrome/web proxy on top of tor)

2 - you configure chrome to use a socks proxy (in the panel options/under the hood/change proxy settings/internet propriety/lan settings/proxy server/advanced/servers, fill the socks fields with the tor settings : localhost and the tor's port)

share|improve this answer

Make sure you have the HTTP space empty. Only fill in the localhost for the socks. The IP is hidden successfully.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .