Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

About twice a day, after switching spaces, the window that indicates which space is active doesn't go away, then all keyboard input is ignored except for Ctrl+arrow key to switch to a different space. The problem is fixed by logging out and back in. I've googled around but haven't been able to find anything. I've also ruled out a sticky control key because it happens whether I'm using the Macbook's keyboard or an external one.

Any ideas?

share|improve this question
This problem stopped affecting my MacBook after I disabled all global keyboard shortcuts in third-party apps that made use of the Control key. – BoltClock Oct 27 '10 at 4:43
I think the only global keyboard shortcut I'm using is for Divvy- cmd+shift+space. I may try removing it anyway if nothing else works. – Rob Lourens Oct 27 '10 at 17:07
I have this problem as well, see this apple.stackexchange post for a few workarounds and other links discussing the topic: Unfortunately, I haven't been able to find a real permanent fix for this anywhere yet. It's incredibly annoying, as spaces are fundamental in my daily workflow. – oyvindio Nov 23 '10 at 18:12

I've had this happen on and off a few times, and sometimes just sleeping/waking solved it. I wasn't able to diagnose this as either a background application, or something else, but I think it went away with one of the SMC firmware upgrades. So, are you fully up-to-date as far as the Apple Software Updates are concerned?

share|improve this answer
Yep, I just installed the latest batch of updates a few days ago, and it has happened before and after those updates. I haven't tried sleeping and waking though. That would be much more convenient since restarting all the applications I have running- often Xcode, iTunes, Eclipse, Word, etc. takes a while. – Rob Lourens Oct 27 '10 at 2:22
Sleep/wake only sometimes got it back to working. You might also try fast user switching (goes to login screen without logging out) but if that doesn't fix it you'll probably have to do a hard boot since you won't have any way of entering your username and password. – roguesys Oct 27 '10 at 2:38
When I had this problem, I had to sleep/wake twice before the keyboard would become responsive. – BoltClock Oct 27 '10 at 4:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .