Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm currently on Windows, and want to switch to Linux, but some hardware issues are preventing me. Mainly, I have a sound card that supports Line-In. On Windows, anything I plug into the line-in gets outputted to the speakers.

However, when I installed Linux, because there is not a control application that comes with the driver, I have no idea how to set this up. I tried going to the sound settings and it doesn't seem to be there.

I also want to configure it for 2.1 sound, and do not know how to do that...

Anyone here done it before?

Thanks in advance for the help!

share|improve this question

migrated from serverfault.com Aug 9 '09 at 21:54

This question came from our site for professional system and network administrators.

    
What sound card do you have? Does sound work in Linux? Why do you want to switch to Linux? What is your experience with Linux? Answering these will help us help you –  basszero Aug 10 '09 at 11:28
    
I have a RealTek sound card, I'd have to check exactly which one. Sound works fine in Linux. I want to switch to Linux because I've always liked Linux better, just haven't had a chance to install since I bought this machine new. I'm experienced with Linux, I work on a Linux machine at work, and have used Linux for many years, including for development. –  hahuang65 Aug 10 '09 at 11:56
    
Did you manage to get this working? –  nagul Aug 14 '09 at 15:54
add comment

5 Answers

up vote 4 down vote accepted

Your sound-card does it. Just open the volume control applet, and move "Line in" channel top the top (you might need to enable the channel configuration slide so it's not hidden).

Also try opening console (gnome terminal), and launch there:

$ alsamixer

You'll get a command-line volume control. Find "Line in" by pressing , and hold untill it reaches 100%. Also check the slider's bottom: if "MM" is there then the channel is muted. Hit M key, and it will become enabled.

Cheers!

share|improve this answer
add comment

I am not sure which versions of Ubuntu this applies to but I know in 10.04 the loopback module to enable monitoring the line-in is not enabled by default. To enable this function issue this command in the terminal:

pactl load-module module-loopback
share|improve this answer
add comment

Im not sure if this helps, But i came across this article a little while ago, and while not specific to your problem is about proffesional audio on linux

http://createdigitalmusic.com/2009/08/04/linux-music-workflow-switching-from-mac-os-x-to-ubuntu-with-kim-cascone/

share|improve this answer
add comment

On some machines there are line in and mic in connections on the front as well as the back of the case, and they are selectable. When using the colume control applet, you might poke around to see if there is a linein-front that needs to be enabled.

share|improve this answer
add comment

I am not sure which versions of Ubuntu this applies to but I know in 10.04 the loopback module to enable monitoring the line-in is not enabled by default. To enable this function issue this command in the terminal:

pactl load-module module-loopback

Adding this to your ~/.bashrc (or the start script of your choice) makes it persistent after each logout/logon.

share|improve this answer
    
Do you have any links to the source? –  ChrisN Jan 3 '13 at 22:27
    
If you refer to the source for the quotation above, I'm sure the user superuser.com/users/93284/greg posted it originally here: superuser.com/questions/20386/…. I just thought it could be of value to relate to this post. –  RickB Jan 15 '13 at 1:08
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.