Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running the following configuration:

Dell Studio 1557 Laptop
Windows 7 Professional x64
Synaptics Touchpad Software 13.2.2.2
Dell Touchpad "driver" 13.2.2.2

While the Synaptics folder is there and appears to be what is actually driving the touchpad, the Synaptics GUI tool has been replaced with the Dell tool (DellTpad.exe). The Dell tool has basic configuration including gestures like pinch-zoom, but it is missing an entry for the 3 finger click gesture (open notepad), which is turned on by default.

I have big clumsy fingers so I already have the 1 touch click turned off (only the hardware buttons click), but I am constantly opening notepad over my work because of the 3 finger gesture.

Is there any way to disable this gesture without the Synaptics GUI? I have looked in the registry and see keys like "3FingerTapAction", but changing this to 0 didn't seem to have any effect.

share|improve this question

3 Answers 3

up vote 0 down vote accepted

You should uninstall the dell driver and the synaptics driver. This should disable all multitouch features. Then install the latest synaptics driver (http://www.synaptics.com/support/drivers) and you should get the options to disable 3 finger click.

share|improve this answer

In my experience I find it best to start from scratch.

Open Control Panel -> Programs and Features and uninstall both sets of software, the synaptic and the Dell.

Then reboot and try whatever Windows installs by default, if that doesn't work, find whatever the newest Synaptic drivers are and try those. Personally I have had trouble with Dell's little helper software on laptops.

share|improve this answer

My fix that actually fixes the problem and enables you to use your Dell touchpad the way it is meant to be used.

Ok, the problem here in short is that Dell driver is using Shell to execute screensave.scr (if you have set Blank Out Screen or Lock Screen option), and shell is opening it in associated application (notepad) and not trying to run it as a program! I have AutoCAD 2012 installed on my PC and it has took .scr extension and made it into a plain text type of file, so this could be why this is happening...

HOW TO FIX THIS (so it works, and not just turn it off)

You need to restore .scr extension to default association. You can do this any way you want, but this might be the easiest one:

  • Copy this registry file contents from here:

Windows Registry Editor Version 5.00

[-HKEY_CLASSES_ROOT.scr]

[HKEY_CLASSES_ROOT.scr] @="scrfile"

[-HKEY_CLASSES_ROOT\scrfile]

[HKEY_CLASSES_ROOT\scrfile] @="Screen saver" "FriendlyTypeName"="@shell32,-10162"

[HKEY_CLASSES_ROOT\scrfile\shell]

[HKEY_CLASSES_ROOT\scrfile\shell\config] @="C&onfigure" "MUIVerb"="@shell32.dll,-10209"

[HKEY_CLASSES_ROOT\scrfile\shell\config\command] @="\"%1\""

[HKEY_CLASSES_ROOT\scrfile\shell\install] @="&Install" "MUIVerb"="@shell32.dll,-10210"

[HKEY_CLASSES_ROOT\scrfile\shell\install\command] @="rundll32.exe desk.cpl,InstallScreenSaver %l"

[HKEY_CLASSES_ROOT\scrfile\shell\open] @="T&est"

[HKEY_CLASSES_ROOT\scrfile\shell\open\command] @="\"%1\" /S"

[HKEY_CLASSES_ROOT\scrfile\shellex]

[HKEY_CLASSES_ROOT\scrfile\shellex\DropHandler] @="{86C86720-42A0-1069-A2E8-08002B30309D}"

[-HKEY_CLASSES_ROOT\SystemFileAssociations.scr]

[-HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts.scr]

  • Open notepad or any text editor and paste it into a new file
  • Save a file with .reg extension, for example FixingDellTouchpad.reg
  • Run the file (double click on it), and VOILA! It now locks the screen when you facepalm it, and it also blacks it out... notepad is gone, and the touch pad works, yaaay! :)
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.