Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a rather annoying issue with my Windows 7 computer whereby it seems to take ages to delete, move or copy folders, even when they are empty. The problem is intermittent, to make matters worse. It just says "Discovering items..." for anything up to a couple of minutes before eventually doing what its told.

Any suggestions on where to look to stop this happening?

I have tried disabling antivirus realtime scanning to rule that out as the root cause.

share|improve this question

7 Answers 7

up vote 5 down vote accepted

I found a huge post with LOT'S of suggestions. It could be related to many things...

First step would be to boot into Safe mode and see if the behavior is still happening. If it isn't you know it isn't Windows related but some kind of system driver (e.g. your antivirus even though you have it disabled).
Other suggestions include thumbnails, file permissions, too many files in a folder, etc... just read through the thread and try some things:

Extremely slow file copying / moving / deleting

share|improve this answer

I've worked around this by moving large folders from the command-line (cmd.exe) instead:

c:\> move c:\stuff\big-folder c:\other-stuff\some-other-folder

This works very quickly for me for dirs under the same drive letter. Also, any explorer window displaying the source or destination dirs updates within a second after the command-line prompt returns.

When selecting and moving multiple items, I use dired-mode (under emacs) which works with similar speed when moving files/dirs within the same drive letter.

share|improve this answer
This works great, not only with directories under the same drive letter. I had this issue of Win7 insisting on "discovering" items on my USB drive, then coming up with a completely fabricated progress bar despite no progress being made, before it finally decided that it couldn't find any files on my USB drive. The next time you plug it in, it claims there are errors on it and wants to scan the drive (even though my Linux machine and others can access everything just fine). So I now have a "transfer" folder and a little batch file to copy that folder's contents to my USB. Works like a charm. –  Amos M. Carpenter Apr 18 at 1:54

I had that same extremely annoying problem, where deleting empty folder would block while "discovering items".

The moment when I killed TSVNCache.exe and/or TGitCache.exe discovering was done and I didn't have that problem anymore. So, not only all that Tortoise stuff asks you to reboot your PC with every update, it also screws explorer badly.

share|improve this answer

I had a similar problem in Windows XP, mostly due to messing up Registry settings. It was so bad that I couldn't access any partition other than C:/ and without going to My Computer.

How I messed up the Registry:

  • Gave full control permissions to SYSTEM for HKCR (HKEY_CURRENT_ROOT)

How I "restored" the Registry:

  • Gave full control permissions to the "Local User" for HKCR.

... but I doubt you, as a regular user, would have messed up the Registry so bad for this to happen. However, it might be a possible cause.

share|improve this answer

In windows explorer go to Tools

Folder Options View Tab and check mark the first option "Always show icons, never thumbnails.

Will solve the problem. If you want to see thumbnails in the folders again, remove the check mark.

share|improve this answer

The problem with Windows GUI is that it tries to calculate the total volume of bytes to be copied before starting the work. While it may not be a problem while copying files within the same hard drive, it can be a major time consumer while copying files across different drives and between computers.

If you are sure that the target drive has sufficient space or don't mind if the copying gets terminated intermittently due to insufficient space, you may use following from the command prompt (cmd):


The above copies all files, all subdirectories, including the empty ones. It starts copying immediately without trying to discover.

Use "XCOPY /?" to see all options.

share|improve this answer

I can not help you with the movement and copying. But I got around the deleting issues with the command prompt using:

del *complete folder path*
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.