Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using Inkscape, and I'm trying to import an EPS file to use it as a vector and eventually save it as an SVG.

This link here mentions several methods:

http://www.inkscapeforum.com/viewtopic.php?f=5&t=797

But the responses aren't rated since it's a forum, so I thought I'd ask here to find the best answer. I'd prefer not to have to use some website to convert the file to a PDF first.

Either way, when I import an EPS into Inkscape, or use the website to convert it to a PDF, in both cases the resulting file loses all colour and gradients, and the EPS file gets cut off on the right side.

It looks like ps2pdf is clipping the file incorrectly, and Inkscape is eliminating the colour.

I have these version installed in Ubuntu Lucid Linux:

Inskape     0.47.0-2ubuntu2
Ghostscript 8.71.dfsg.1-0ubuntu5.3
share|improve this question

3 Answers 3


It seems like a known issue: http://www.inkscapeforum.com/viewtopic.php?f=5&t=797
Workaround: convert to PDF using http://convert.neevia.com/

Good luck :-)

share|improve this answer
3  
Neil has ghostscript installed. Why not convert to PDF using ghostscript? epstopdf <filename> on the commandline. –  frabjous Oct 29 '10 at 14:50

Yeah - its broken pretty much. Just ran into this.

Try importing it into Scribus. Then export it as something else and reimport in Inkscape. PDF works much better if you can get it to that. You can also use 'epstopdf' command...

share|improve this answer

This link: importing-eps-files-into-inkscape contains a very detailed tutorial on how to do this and it worked perfectly for me. It is based on instructions found at inkscapeforum.com, specifically this quote from eelke:

Inkscape's PS and EPS import now uses Ghostscript instead of pstoedit. If you need to open files of these types, install Ghostscript and make sure the directory with the ps2pdf utility from Ghostscript installation is in your PATH. On importing a file, you will see a preferences dialog, similar to PDF import; for multipage PS files, this dialog allows you to select which page to open.

It works only when you put both links; "bin"and "lib" from Ghostscript in : exc. C:\Program Files\gs\gs8.70\lib;C:\Program Files\gs\gs8.70\bin Start -> Control Panel -> System -> Advanced; Click on Environment Variables, under System Variables, find PATH (or make it in the new..), and click on it. In the Edit windows

That is the gist of the solution. The tutorial in the link at the top of this answer shows how to do this step-by-step with pictures.

share|improve this answer
2  
While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. –  Shekhar Dec 18 '14 at 0:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.