Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

For whatever reason, on my Ubuntu install of Firefox, my spellcheck tells me 'flavor' should be 'flavour' and 'initialize' should be 'initialise', etc.. At first, I thought I was crazy and had been spelling it wrong my whole life, but I suddenly realized (ugh there it goes again!) that the spellchecker must be configured for UK English or something. Where can I change this to US English?

Note that I know it is isolated to Firefox, because other applications that have spellcheck on my system are not doing this.

share|improve this question
add comment

2 Answers

up vote 6 down vote accepted

In any text box in Firefox, right-click, and you should see a menu item "Languages". Select "English / United States".

share|improve this answer
1  
The problem with this answer is that once you restart the browser, you have to do this again. –  Ken Jun 21 '13 at 16:49
    
To prevent it resetting back to en-US (under Windows anyway), you can go into the dictionaries sub-folder within the installation folder and delete the en-US.aff and en-US.dic files. I'm sure there is probably something similar for Linux. –  Richard Feb 3 at 16:40
add comment

Get any language you like at https://addons.mozilla.org/firefox/language-tools/ and then disable every language you don't like through menu Tools, Add-ons.

Or, if you want to have multiple languages installed: after installing them, right click in any text box and choose sub menu Languages to select your favorite/favourite.

share|improve this answer
1  
I've had the same issue on Ubuntu and disabling languages through the Add-ons dialog hadn't worked. –  Firefeather Nov 20 '10 at 5:06
    
@Firefeather, some OS built-in spell check maybe? (On my Mac, the spell checking in Safari is using the built-in spell check, but in Firefox I still need to add language as an add-on.) –  Arjan Nov 20 '10 at 8:02
    
sorry, let me be more clear. On Ubuntu, Firefox still uses its own spelling dictionary, but even disabling the installed-by-default en-GB language add-on doesn't work. But the text box right-click approach does solve the problem as long as there is a dictionary installed with en-US spellings. –  Firefeather Nov 20 '10 at 18:51
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.