Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've entered a lot of queries into wolframalpha.com. When I go back to the site, and try to type in something I've typed before, nothing happens. On other sites, like superuser.com, if I type into the search box, Firefox remembers my previous queries and suggests them to me. Why doesn't this work on Alpha? Can I make it work with a greasemonkey script?

<form method="get" action="/input/" accept-charset="UTF-8" autocomplete="off">
    <div id="input-background">
        <input name="i" id="i" maxlength="200" autocapitalize="off" type="text">
        <a id="iClear" style="display: none;"></a>
        <label class="hidden" for="equal">Calculate</label>
        <input id="equal" title="compute" value="Submit" type="submit">
        <div id="howTo"></div>
    </div>
</form>
share|improve this question
add comment

2 Answers

up vote 5 down vote accepted

Wolfram Alpha's search box has autocomplete="off" property, and hence this is respected by browsers and the input box is not filled in. I couldn't find any greasemonkey scripts to change this behaviour


There is an alternative, however. Keep in mind - that this enables auto complete for everything.

1. Locate Firefox’s installation folder. Normally that’s C:\Program Files\Mozilla Firefox

2. Navigate to the components folder.

3. Open nsLoginManager.js in an editor.  As Notepad won’t do really, do this instead [if you've a proper editor, just go to step 4]:

3a) Select  Start | Run

3b) Enter cmd <enter or Ok>

3c) type cd C:\Program Files\Mozilla Firefox\components <enter>

3d) type edit nsLoginManager.js <enter>

3e) Go to step 4.

4. Find this:

    /*
     * _isAutoCompleteDisabled
     *
     * Returns true if the page requests autocomplete be disabled for the
     * specified form input.
     */
    _isAutocompleteDisabled :  function (element) {
        if (element && element.hasAttribute("autocomplete") &&
            element.getAttribute("autocomplete").toLowerCase() == "off")
            return true;

        return false;
    },
5. Change it to this:

    /*
     * _isAutoCompleteDisabled
     *
     * Returns true if the page requests autocomplete be disabled for the
     * specified form input.
     */
    _isAutocompleteDisabled :  function (element) {
        return false;
    },
6. Save the file [if you're following the 3x) steps above, select File | Exit, and when asked if you want to save the edited file, answer Yes.  To close the command prompt, enter exit <enter>].

Note that you might first have to change the file’s security permissions to do this [you DO if the save fails].  E.g., in Vista I had to A) right-click on the file [e.g., in Explorer] B) select Properties | Security. B) select Edit. C) select your username, D) change the persmissions to include Write access.

And you’re done – either start, or close/re-start Firefox!
share|improve this answer
    
Aha! I've also seen the opposite, where a credit card field is marked as autocomplete=on, and it remembers when it shouldn't. It would be great if there were an extension or script that let us individually disable/enable it for special cases like this. –  endolith Oct 29 '10 at 20:06
add comment

And here's how to enable it for a specific site using Greasemonkey:

// ==UserScript==
// @name           Alpha autocomplete on
// @namespace      
// @description    Enables browser form history for Wolfram Alpha
// @include        *wolframalpha.com*
// ==/UserScript==

document.forms[0].setAttribute("autocomplete", "on")
share|improve this answer
1  
Thanks @endolith –  Sathya Oct 29 '10 at 21:06
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.