Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have used this script to install imageMagick:

Google: maddox magik-installer - its the first hit

My terminal name is a string of cryptic letters and numbers. See image here:

enter image description here

Keep in mind my computer name in the "Sharing" system preferences is localhost.

Any ideas how to change this?

share|improve this question

migrated from stackoverflow.com Oct 28 '10 at 22:55

This question came from our site for professional and enthusiast programmers.

add comment

2 Answers 2

That's the hostname of the system as assigned by DHCP. Either set up a different hostname to use and override DHCP, or modiy $PS1.

share|improve this answer
add comment

The imageMagick installation must have altered your .bashrc file. You'll want to edit it to something like export PS1="\u@\h\w$ " - specifically, you're setting the PS1 environment variable.

See http://osxdaily.com/2006/12/11/how-to-customize-your-terminal-prompt/ for more explanation and options.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.