Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

To be precise

System has reached the maximum size allowed for the system part of the registry. Additional storage requests will be ignored.

WinXP/64 running fine for 2 years (no /3Gb switch), just started happening. I used ntregopt and the problem went away at least temporarily. However, looking before and after in Windows\System32\Config I see that my System file was reduced only by 10% and is still 170+ Mb. According to my rather extensive research with Google, this is "huge" and should be more like 10-20Mb. The system runs fine. There is a System.bak that is only 11Mb and has the date when I ran ntregopt.

That's what I know. Now my question: Is there anything I can do to reduce or rebuild the System registry hive given the above info?

share|improve this question

migrated from Oct 29 '10 at 4:24

This question came from our site for system and network administrators.

Oh, and I installed the latest nVidia drivers (one probable old wives' tale advised that the problem could be due to old nVidia driver). – Bob Denny Oct 27 '10 at 2:26
Which version do you have installed? I'm assuming the problem existed pre-install and that was an attempt to resolve it? – Cypher Oct 29 '10 at 2:40
Cypher - Yes, 9/1/2010 now. It didn't stop the message from appearing at login. – Bob Denny Oct 31 '10 at 16:15

This article seems to have some information that may help. It does go over some steps you may have already tried (ntregopt), but it includes a link to a tool you may have yet to try to clean your registry of dead entries: vxscrub.

I'm not big on these registry cleaners, but some people rave about ccleaner, which contains a module that also cleans your registry of dead entries.

Personally, I would opt for a data backup and an operating system re-install for a more stable system. That depends on your environment and available time, though.

I found this post which seems to imply that this error is caused by a corrupted swap file. Since you've already tried the first suggestion in the post, I would try the second, added recommendation (cross posted here for easy reference):

The page file needs to be overwritten as it has been corrupted. Follow the following steps:

  1. Enter System in control panel (classic view)
  2. Click on the Advanced tab
  3. Click the settings button under "performance"
  4. Click the Advanced tab in Performance Settings
  5. Click Change virtual settings
  6. Choose No paging file on the settings and click Set
  7. Exit and restart the computer.
  8. Repeat the first five steps of these instructions.
  9. Choose System managed size on the settings and click Set
  10. When you exit you will be asked if you want to overwrite the previous page file. Allow this action.
  11. Restart your computer. You will be rid of the error message. Also, your programs may run better.

I still think it could be a corrupted swap file. Have a look at this document, which outlines the procedure a lot more. Are you sure you removed the swap file, rebooted, then re-created it?

You might also want to try the User Profile Hive Cleanup Service. Some people have reported success with that.

If indeed the size of the system part of the local machine hive has filled up, then I don't think there is a solution other than removing some software and running a second machine - be it virtual or physical. This would be really interesting to see; in all my professional career I have never seen a legitimately filled registry.

share|improve this answer
+1 on backup and re-install. Rarely is there a reason not to on a desktop machine when face with a serious issue. – phoebus Oct 27 '10 at 14:45
It took me 11 days to configure this machine with all of the developent tools (VS2005/2008/2010, Liquid, Eclipse, Tons more), SVN repository links on dozens of working copies of projects, special shells, Office, Sony Vegas and plugins, Dreamweaver, on and on. It really did take 11 days to build this thing. I've never had to "reformat my hard drive" in 15 years of doing Windows development. I use Acronis to image and recover from big trouble. So there is a huge reason not to reformat. I was looking for something a bit more targeted :-) – Bob Denny Oct 28 '10 at 21:15
No offense, but if it takes you 11 days to install software, you're doing something wrong. Been doing sysadmin and software engineering for an equal amount of time as you, and find it always saves me huge amounts of time by doing a clean windows install when the OS starts to act up like this. Whether that means a literal installation, or simple re-imaging the machine with a clean installation, the idea is the same. If you have your data backups all setup, it takes half a day to get a clean install up and running on even the most complex desktops. – Cypher Oct 29 '10 at 2:23
If you have system restore enabled on your desktop, do you have a restore point you could revert to? Alternatively, since you use Acronis, do you have an image you can roll back to? – Cypher Oct 29 '10 at 2:26
don't go back far enough. It happened first at the beginning of Oct, I ran NTREGOPT and it cleared for 3 weeks. I have 2 weekly Acronis backups but they are from after it happened the first time. I'm getting the sinking feeling... – Bob Denny Oct 31 '10 at 6:03

The registry may have "dead" entries, if there were applications and hardware changes. There are a number of online resources available by searching against "registry cleaner" as the search term.

share|improve this answer
I'm sorry I didn't mention that I have run the CleanMyPC registry cleaner regularly over the last 2 years. I agree that there must be a lot of dead info in the System hive, but apparently this cleaner doesn't see/touch it. – Bob Denny Oct 27 '10 at 2:40
You might check with another utility to see if it helps out the situation. – Anonymous Oct 27 '10 at 5:41

This is so strange... As I pointed out in comments, I decided that the message was false. I have now used the system for a week doing heavy development, including testing a complex installer that registers a bunch of old VB6 and newer .NET based COM objects repeatedly. I'm very careful that I don't change GUIDs thus creating a bunch of dead registry entries, by the way! Success for all this time, no problems with the registry.

Anyway, I ran into a separate bizarre problem last night, where I decided to use System Restore (which I've only used one other time in several years). The System Restore failed, saying it could not restore to that checkpoint and that nothing was changed.

On a lark, I decided to have a look at that \config\system file (system hive) and WHAT??? It had shrunk from 196Mb to 7Mb! the error on boot was gone! Something in the last few days, which included a few reboots for the other unrelated problem, caused the system hive to shrink back down to where it should be.

So this isn't an "answer" as such, it's just a war story which ends in a mysterious "self correction" of the original problem. I have no idea what fixed it.

share|improve this answer
Oh, and the system is running fine. – Bob Denny Nov 5 '10 at 16:59
Well doesn't that figure. LOL! Glad your system is back on its feet. – Cypher Nov 18 '10 at 21:15
Cypher - Thanks for your help. I ended up deciding to go to WIndows 7 anyway, for other reasons related to development. It took me 5 days straight to get everything installed and configured. Quite a chumk of time out of my schedule, but I'm now glad I did. It's snappier and more fun to use. – Bob Denny Nov 22 '10 at 22:48

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.