Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have had the same wireless network setup for years (3 Linksys routers, two of which are configured as APs). All of a sudden, one of my notebooks (Win 7, 64 bit) can no longer connect. All my other machines (several notebooks of different types and makes) still connect just fine.


  • After boot, network no longer auto connects.
  • In the network connections, the network still sometimes (very infrequently) appears in the network list, but when trying to mouse to it to connect the network disappears from the list.

What I have already tried:

  • moved the boot disk to a different machine (same hardware, both Dell Lattitude D830, Intel 3495ABG). Same problem, so does not seem hardware related.
  • System restore to day before (when things worked fine) as there were some Windows updates (0ct 27 2010), problem remains
  • removed network from wireless network list, problem stays
  • manually re-added network, did not solve problem
  • remove wireless device through device manager. Shows up again after reboot, same problem
  • Disable IPV6 on the adapter, no change.
  • install new driver (from Intel site), problem remains
  • reset IP & winsock through netsh, problem remains
  • clear out all network cache entries from registry, no difference

Anything else I could try before throwing in the towel and reinstalling?

EDIT: Interesting. When I am connected to the wired network by an Ethernet cable (different network adapter, by Broadcomm), the wireless network does show up and I can even connect to it and stay connected even when I remove the wired network cable and roam the house from AP to AP. However, when I start up not connected by wired cable, the wireless problem is still as described above.

UPDATE I can get the networks to show up by restarting the WLAN Autoconfig service, then disabling and re-enabling the adapter. Unfortunately the machine tends to lose the network again after a while (can be minutes to hours).

UPDATE The issue seems to have disappeared as mysteriously as when it appeared. Getting a new machine shortly, so I will drop the case for now unless new info turns up.

share|improve this question

It could be a power issue see this link (Microsoft forum)

"If you are having a problem with your wireless connection after resuming from hibernate or sleep, or are having intermittent connectivity issues, try to adjust your Power Management profile to change your Wireless Adapter Settings to Maximum Performance. a. To do this click “Change Plan Settings” next to your Power Profile, and choose “Wireless Adapter Settings” and set it to Maximum Performance. You should do this with all of your power profiles. Additional guidance is available here: "

share|improve this answer
Thank you for the resonse. I already had this setting on maximum performance on this system. – Peter Stuer Oct 29 '10 at 8:50
It sounds like the Windows updates may have caused this issue. Did you remove the updates via the Programs (or Programs and Features if you are in advanced mode) option in Control Panel? or did you just do a System Restore without doing this? – BSDIT Oct 29 '10 at 9:26
removed the ones that could be removed. Later did a system restore to remove the "unremovable" update . – Peter Stuer Oct 29 '10 at 10:36
I've had a similar issues with updates over the years and due to our Technet Subscription we were able to call Microsoft to resolve it. Unfortunately I don't have this at home and I had to rebuild the OS from scratch as it was easier and quicker as I had all my stuff backed up. If you can't remove an update it's likely that that is causing the issue, you could try re-installing that update and then uninstalling it an trying again? – BSDIT Oct 29 '10 at 13:18

Have a look in the properties of the wireless connection and see whether the encryption method has changed from TKIP to AES or vice versa - XP and Vista, at least, have an annoying habit of flipping this occasionally and it causes the kind of symptoms you describe.

share|improve this answer
No. Still on TKIP as it should be for this network. – Peter Stuer Oct 29 '10 at 8:50

I had a similar issue. Windows 7 wireless client stopped connecting to my wireless AP. I 'fixed' the problem by disabling/enabling the wireless adapter in Windows: "Control Panel" -> "Network and Sharing Center" -> "Change Adapter Settings". Right click on wireless adapter then "disable". Right click again and "enable".

My Windows 7 client connected successfully after this.

share|improve this answer

I experienced the same problem on my Windows 7 machine. I pressed the button to turn off wireless access. Later I turned it back on but then it would not connect. I restarted the machine and it still would not connect. I then powered it off, left it for a few minutes and powered it back on. After that it connected. Sounds like windows 7 was "being clever" and turned off something to save power. Note bot while being able to connect I was still able to connect with Vista.

share|improve this answer

You can also try to :

  • Disable iPV6 on the wireless adapter.
  • Use "route print" to a file, and compare before and after the problem appears
  • Open "Network Connections", and compare status before and after the problem appears

If any differences are found between the status before and after the problem appears, this might help to pinpoint the problem.

share|improve this answer
Sorry, already tried that.No success. I'll add it to the list. – Peter Stuer Oct 29 '10 at 11:39
Peter: I added some ideas for more tests. – harrymc Oct 29 '10 at 17:55
Thx Harry. I'll try those. – Peter Stuer Oct 29 '10 at 18:25
Neither yielded anything interesting I'm afraid. – Peter Stuer Oct 29 '10 at 20:06
Do you mean that everything was identical before and after? It would be quite puzzling losing Internet yet all routes stay the same. More tests you could do: (1) When Internet is lost, try going to by its IP : (2) If the router has status displays, can you find anything that changes for your computer. – harrymc Oct 29 '10 at 20:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .