Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

We are on a company intranet and most of our time involves cutting our data into reports using our Cognos 8.4 tool. To take the on-screen result into Excel (2007, in XP with IE8) I can either export as XLS (which now opens automatically thanks to an excellent reply by M. Palavuzlar elsewhere on this site) or if wishing to import data into a previously formatted sheet, I can choose to export in CSV.

Does anyone know a way of getting rid of the 'open or save' prompt - and just open? Perhaps from the URL of the tool as it's trusted?

I don't know if I should be looking at Excel, Windows or IE's setup or all three. Or if it's not possible. Any suggestions would be great!

share|improve this question
    
Where do you get this dialog: Cognos or Excel? And describe better the procedure that you follow. – harrymc Oct 29 '10 at 11:32
    
Apols, I'll clarify. Once the data I need is on screen I click the 'download CSV' icon and IE's "File Download" message appears (Do you want to open or save this file?). The message box also dispays the file opens with Excel and that the source is my intranet data server (so as trustworthy as you can get!). I suppose a better phased question is, that if IE knows all this, can I set up that CSV files from this location are always opened, not saved, thus removing the open/save prompt altogether? I suppose it's an IE or file-type-options setting rather than cognos or excel themselves. – John Allan Oct 29 '10 at 12:46

How to do that for a given file-type, .csv, is described here:

Reset Open/Save Choice for Internet Explorer Downloads in Vista

But I don't know of a way to condition it upon the source website.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .