Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This is similar to this question in SF, except that this is happenning on my laptop where my user id is part of the administrators group.

The fonts that I install disappear after a reboot. I need these fonts really badly for 2 reasons: 1. Certain fixed-width fonts I'm too used to for programming/IDE/Emacs. 2. Special fonts for viewing content in indian languages.

Any ideas on how I can prevent this from happenning ?

Scenario:

  1. Boot-up & login into windows using my user id.
  2. Install a new font (Goto C:\WINDOWS\Fonts, click File -> Install new font..., point to location, select Copy files to fonts folder, click OK)
  3. New font is installed. It is visible in all applications e.g., in Microsoft Word and GNU Emacs.
  4. Restart the computer and login into same user id.
  5. The new fonts installed in step 2 are gone ! They are not accessible in any application.

I checked the following:

  1. I am using windows XP.
  2. My userid is part of Administrators group
  3. In terms of windows permissions (security tab in folder properties) Administrators group has full control over the C:\Windows\Fonts folder
  4. Even after reboot the font files are present in C:\Windows\Fonts folder and I cannot reinstall them. When I try to reinstall I get an error dialog

    alt text

  5. Only the new fonts I have installed are missing.

  6. The registry key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Fonts shows these fonts mapped to the corresponding font files.
  7. In HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\IniFileMapping\win.ini the value Fonts is mapped to data SYS:Microsoft\Windows NT\CurrentVersion\Fonts (it was #SYS:Microsoft\Windows NT\CurrentVersion\Fonts by default).
share|improve this question

2 Answers 2

I found this on a site and this worked for me.

If font files are encrypted (green colored) they become locked and not available after reboot. right click your font (in its folder before you install it), click "properties," "Advanced," and uncheck "Encrypt contents to secure data.

Then install the font.

share|improve this answer
    
Thanks. That's exactly what I found out when I solved this problem and recommended in my answer (where it goes "decrpyt manually the copied font files...). However it seems to me that making sure they are not encrypted before even installing them is a cleaner solution. –  koushik Oct 6 '13 at 6:23
up vote 0 down vote accepted

I have a found a solution for this that works. Apart from the things I already checked (thanks to SF and some other links ) there was 1 final item that needed to be sorted. The root-cause of the issue seems to be related to encryption.

There are a couple of folders in my computer which automatically get encrypted by windows (these are shown in green colour in explorer). When I install the fonts from within this folder (using the option "Copy fonts" - then Windows cannot read back the copied font files upon reboot. This is probably because it tries to load the font before it loads the encryption/decryption service.

I found this by accidentally installing from a different location (because I wanted to copy shortcut etc).

The solution is to install from a location where the files are decrypted or decrypt manually the copied font files (by choosing File -> Properties and in "General" tab, Clicking on Advanced and then deselecting the "Encrypt contents..." checkbox.

So, the updated checklist to ensure user-installed fonts don't disappear in XP after reboot is below.

  1. Make sure the userid is part of Administrators group or Powerusers group - henceforth called the A/P group
  2. In terms of windows permissions (security tab in folder properties) A/P group should have write access to the C:\Windows\Fonts folder
  3. The registry key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Fonts should be fully modifiable by the A/P group.
  4. In HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\IniFileMapping\win.ini the value Fonts should be mapped to data SYS:Microsoft\Windows NT\CurrentVersion\Fonts (it is #SYS:Microsoft\Windows NT\CurrentVersion\Fonts by default). I don't know if this step is necessary
  5. Make the sure the font files are not encrypted. If you choose to copy the font files, either install them from a source folder that is not encrypted or manually decrypt them "in-place" (C:\Windows\Fonts) after installation. If you choose not to copy the font files then make sure the the files are stored without encryption.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.