Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've got a linux box with a static IP configured that seems to be ok. The static IP address works for a few hours, and then sets itself back with (what seems like) whatever DHCP tell it to use.

Here's my /etc/network/interfaces

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
address 10.0.0.101
netmask 255.255.255.0
network 10.0.0.0
broadcast 10.0.0.255
gateway 10.0.0.254

Any ideas?

share|improve this question
    
You could ask this in askubuntu.com or unix.stackexchange.com and get better/faster answers –  Toto Oct 29 '10 at 18:20
    
I believe this is my problem: superuser.com/questions/99034/…. Gnome is trying to manage my network for me. Thanks for the suggestion though. –  shady Oct 29 '10 at 18:49
1  
This looks like NetworkManager acting up. Do you have NetworkManager running? Do you want to? –  Gilles Oct 30 '10 at 0:25
    
That's what the problem was. I disabled the Gnome networking and it's been ok. Thanks for the help. –  shady Nov 14 '10 at 4:44

1 Answer 1

I got the same problem on Ubuntu Server, but I think I managed to solve it. When I restart networking, dhclient3 is still running. Looking at it from htop, it has some “eth0″ in the arguments, so I suspected it was still looking for renewals of dhcp for eth0. I failed to remove dhcp-client with apt-get, so I ran:

sudo kill $(ps -aux | grep dhc | grep eth0 | awk '{print $2}')

NOTICE: This code might kill other things on your server! Take it easy and replace “eth0″ with the interface name for which you have set a static IP! Alternatively kill dhclient OR dhclient3 for your interface through htop.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.