Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running Parallels 4.0 on Mac OS X 10.5.8.

I'm trying to create a bunch of Virtual Machines from the commandline, using the prlctl tool, like so:

$ prlctl create test1 -o linux -d centos
$ prlctl set test1 --device-del cdrom0
$ prlctl start test1

Now, each time I start a new VM, the VM spends time waiting for a PXE boot. I'd like to turn this off.

Can I disable PXE requests using Parallels or a Parallels commandline tool?

Or, can I set the boot order of a VM from the commandline?

share|improve this question
    
You might want to accept your answer, so this topic doesn't get bumped again by Community. –  Daniel Beck Jan 16 '11 at 10:45
    
Thanks for the reminder @Daniel. Done. –  Stefan Lasiewski Jan 18 '11 at 19:06

1 Answer 1

up vote 0 down vote accepted

Figured it out!

The Boot Order is determined by the order in which you create the devices. So, the following example will boot with the CDROM first, then the Network card. PXE is therefore never used:

$ prlctl set test1 --device-del cdrom0
Remove the cdrom0 device.
The VM has been successfully configured.
$ prlctl set test1 --device-add cdrom --enable --image /Users/stefanl/Downloads/Mirrors/CentOS/CentOS-5.5-x86_64-netinstall.iso
Creating cdrom0 (+) ide:1 image='~/Downloads/Mirrors/CentOS/CentOS-5.5-x86_64-netinstall.iso'
The VM has been successfully configured.
$ prlctl set test1 --device-del net0
Remove the net0 device.
The VM has been successfully configured.
$ prlctl set test1 --device-add net --enable
Creating net0 (+) type=shared mac=001C42F15907
The VM has been successfully configured.

My boot order is now:

  1. Floppy
  2. CDROM
  3. Network card
  4. HDD
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.