Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I get following error when i try to connect via "HeidiSQL" to my database server (local network)

SQL Error (2003): Can't connect to MySQL server on 'X.X.X.X.' (10051)

SSH Connection via Putty works fine. I checked the my.cnf file on the server (Ubuntu), but settings like bind_address are correct.

Is it possible that my wireless modem (SpeedTouch) makes this trouble? (Because my provider changed the download speed) !

share|improve this question
    
you check heidi forums? heidisql.com/forum.php?t=5428 –  Tommy Sep 14 '11 at 22:57

1 Answer 1

If you can't connect to your server directly, but can connect through a SSH tunnel then usually the server is just only listening on localhost. As far as I know, that is the default on Ubuntu system.

When you say the bind-address is "correct", then I assume you changed it to your public IP address. In that case, make sure you restarted mysqld after you made that change.
Additionally, the listening port (3306 by default) could be blocked in ufw or some other firewall in place.

share|improve this answer
    
+1 for firewall. Also quite likely that skip-networking is enabled in the config. –  Garrett Nov 15 '11 at 17:34
    
Ubuntu's default is to just listen on localhost, not to have skip-networking –  cpast Jan 2 '13 at 5:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.