Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So this is a problem I've had pretty consistently since I got my cable broadband hookup, and its starting to get on my nerves.

When I'm just doing regular browsing or playing a game, its fine. But when I start streaming movies and video or downloading via bittorent, it'll sometimes just disconnect. Usually unplugging the router and plugging it back in will fix it, but sometimes I have to unplug the cable modem too. And sometimes I have to unplug both of them twice to get my internet back.

I use a personally-owned Motorola cable modem that I bought a few days before the cable guy came so I don't think that its broken, and I have a Linksys E2000 router, which is one of their better consumer models. So I don't really know what the problem is here. I want to call the cable company and get someone out here, but I want to be sure its not a problem with my own hardware.

My router links my PS3 and my computer with a wired connection, and my phone wirelessly.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

If you have connection issues, simplify things or you'll never figure out what is going on.
If you direct connect to your modem and stream, do you still get disconnected? Routers fail fairly frequently. Even if you paid $600 for your enterprise grade router yesterday, it can still fail today, it happens, never rule it out as a possibility just because you don't think it should have failed.
Have you tried swapping out cables? Bad cables are a very common cause of poor or intermittent connections. This includes ALL cables, including those in your walls. Sync up at the cable junction box with a laptop if you need to.
Have you checked to see if your cable company is having issues with their CMTS? This is not as likely, but can be a possibility if you've ruled out layer 1 issues on your side.

share|improve this answer

Have you made sure to update the firmware on each device to the latest version? I had a similar issue with my linksys router and updating the firmware helped a lot.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.