Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

All of my windows in Ubuntu Maverick are missing the Min-Max-Close buttons. Additionally, I cannot move or resize them. Windows that open at the top of the screen obscure the menu bar making the Applications, Locations, and System menus inaccessible.

I have tried 'sudo dpkg-reconfigure gdm' 'sudo dpkg-reconfigure metacity' 'sudo dpkg-reconfigure gnome-session' and 'sudo dpkg-reconfigure mutter' with no success. Also I tried doing a full install of compiz, fusion, and emerald via Synaptic PM and then launched Compiz Configuration Manager and that did not change anything either.

Opening System>Preferences>Windows nets the error message "Cannot start the preferences application for your window manager. Window manager "unknown" has not registered a configuration tool." Clicking the desktop icon at the left side of the task bar (dock?) gives the error message "Your window manager does not support the show desktop button, or you are not running a window manager."

Is there anything I can do to get normal window functionality back short of a nuke & pave?

share|improve this question
    
Can you provide an update. –  Tshepang Jan 27 '11 at 5:22

1 Answer 1

Somehow the window manager doesn't start, hangs or crashes (so indeed, it isn't managing windows, and no window borders get drawn).

It is very well possible that switching off the visual effects makes things work again (that will launch metacity and make Ubuntu use it).

If you still want to use Compiz, it's possible that it's crashing or freezing because of 1 effect, and disabling that can make compiz work again, but it's not always easy to know what causes it.

share|improve this answer
    
Thank you, but I cannot access any window settings. –  penguirl Nov 1 '10 at 0:27
    
The "visual effects" settings are in System --> Preferences --> Appearance. Are you sure you can't open that dialog? –  JanC Nov 3 '10 at 18:31
    
Otherwise, try Alt+F2, then start the command "metacity --replace" to get a window manager running first. –  JanC Nov 4 '10 at 14:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.