Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a video in Matroska format (MKV, file extension .mkv), 3D half-SBS, where the 1280x720 frame shows the left-eye frame on the left and the right-eye frame on the right.

I don't have a 3DTV, but I have NVidia 3D Vision: I tried to open it with PowerDVD 10 with no result (program hangs). With the same PowerDVD, I tried to play the Avatar 3D trailer downloaded from YouTube (MP4 format), but it now shows it the two frames.

PowerDVD 10 is advertised to support 3D and 3D Vision. Why can't I play these videos?

NVidia Stereoscopic player plays the Avatar trailer fine, but it doesn't support MKV.

share|improve this question
    
why you are converting mkv to vob? you all lose resolution –  user135628 May 22 '12 at 16:51

4 Answers 4

PowerDVD 10 Ultra Mark II should be able to play 3D half-SBS MKV files. Did you try enabling 3D by clicking on the "3D button"?

I have had better luck with Stereoscopic Player when it comes to 3D MKV files. If Stereoscopic Player fails to play the file, try installing K-Lite Codec Standard Pack.

share|improve this answer
    
That is the PowerDVD version I have. It hangs when trying to play MKV. Trying K-Lite –  djechelon Oct 31 '10 at 16:12
    
I DID IT!!!!!!!! K-Lite solved the problem, but I had to enable the AVI splitter in Stereo Player manually, probably because I have installed it prior to the codecs :) –  djechelon Oct 31 '10 at 22:30

Bino 3D supports playing MKV, and is free+open source:

http://bino3d.org/download.html

share|improve this answer
    
Hi, Bino doesn't support NVidia 3D Vision, which is what I wanted. Anyway it looks great with Discover or native TV that play SBS –  djechelon Dec 29 '12 at 23:27

I encountered this problem when I tried playing the half side-by-side MKV on my Samsung 51" plasma which is 3D enabled.

However when I converted the file to .VOB keeping all parameters intact, the 3D played like heaven.

share|improve this answer
up vote 1 down vote accepted

Solution is to install K-Lite codec pack and use 3D Vision player to play the files! You must select a proper splitter for Matroska. In my case, FLV splitter worked fine!

Screenshot

share|improve this answer

protected by slhck Jun 9 '12 at 8:56

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.