Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

EDIT

Nevermind, probme seems to be the router, tried resetting it to factory defaults, doesn't help either. It's a WRT54GS v5.1 Linksys router

END EDIT

For some reason my laptop with windows 7 can't connect to my router properly anmore.

The router is a Linksys with a mac-address filter. The laptop has always had good connection on it.

I've reset the router, tried updating drivers, done diagnostics, troubleshooter, etc, I get results like this:

problem with wireless adapter or access point

a network cable is not properly plugged in or may be broken

the default gateway is not available

Sometimes the tray-icon shows connection with excellent signal strenght, only when opening the network dialog box it shows a warning sign on the connection, and the internet is either still not working or incredibly slow.

Also checked windows event logs, they just say it can't connect, no response from router received, etc ...

I've seem to been through all the normal windows help tools and they don't help. If I plug it into the router directly it works fine though but that's not very usefull on a laptop.

What's the best way to figure out where the problem really lies? Or does anybody have any ideas on what else to try?

Edit: This is the only thing that seems to really point me in a direction in the event logs of Diagnostics-Networking:

Profile match: Success

Pre-associatoin: Success

Association: Fail

Security and authentication: Not started

Association status: Fail 0x00038002

Association reason code: 0x00000002

share|improve this question
    
Uninstall and reinstall the network card driver. Also try "repair" on the network once it's reinstalled. –  user3463 Oct 31 '10 at 18:10
    
Done this through device manager, no effect. What do you mean by repair? Where do I find this option? –  Rakward Oct 31 '10 at 18:35
    
I tried the repair automatically in the CP->Troubleshooting->Network/Internet->Network Adapter box, but also no effect –  Rakward Oct 31 '10 at 18:44
add comment

1 Answer

Is this happens to all Wireless networks probably the problem with you NIC , if only happens to this router it may some wrong configuration with you router

Try Reinstalling the NIC drivers Make sure to install the manufacturers NIC driver release not a default driver provided by windows

share|improve this answer
    
Okay, just tried connecting with my desktop wich used to connect with a USB, and it also could not connect, so it must be the router, but how to find the problem? –  Rakward Oct 31 '10 at 18:49
    
some times may be some one has played up with your router ;) , try resetting the settings to default . whats your router model ? –  Sudantha Oct 31 '10 at 18:52
    
WRT54GS v5.1, I went to linksys helpdesk and they just said it's out of warranty and that I had to call they phone service, what rip off. I'm gonna try the rest now, hopefully I can get it back working again. –  Rakward Oct 31 '10 at 19:17
    
great good luck with it ! –  Sudantha Oct 31 '10 at 19:18
    
Resetted to factory defaults, no effect. –  Rakward Oct 31 '10 at 19:25
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.