Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Situation:

  • I wish to record "what i heard" while using the PC using either digital/analogue/software loopback.

My configuration

  • E-MU 0404 PCI sound card
  • Windows 7 Ultimate (x64)
  • Audacity / Audition 1.5

I had tried in similar situation before in windows xp and i was able to do it by setting a 'SEND WAVE L/R - HOST' send effect in Patchmix DSP. All frequencies are set to 44.1kHz. Clock is internal.

However, when I tried similar configuration in windows 7, while I was able to record audio from the loopback, the audio was extremely distorted and close examination of waveforms shows very short fragments of audio intersparsed with digital silence.

What could be the problem?

share|improve this question

2 Answers 2

Since you didn't mention latency, I consider very likely that you need to set a higher latency buffer size.

I know I'm late but whatever!

share|improve this answer
1  
Unfortunately I do not have the interface with me anymore. I have since switched to something else :) Thanks anyways. –  bubu Jun 11 '11 at 16:37

For others that are still looking.

I've got a similar - if not the same - problem. When I zoom in on the waveform I notice gaps of 2048 samples are present.

One of the tips I found elsewhere is to make sure that Windows does not allow applications to open the device in exclusive mode. Disabling this fixed it for me.

Opening the device exclusively is something from the 'old school' days it seems: there is no need for that anymore. I think the Windows kernel audio mixer will nowadays make sure the sample conversions and other magic happens behind the scenes.

So, how to deny exclusive mode to applications? Go to control panel. Choose "Hardware and Sound" Double click the "Sound" icon

Navigate to the "Playback" tab: Locate the entry that corresponds to your E-MU card (for me that's "2-E-MU E-DSP Audio Processor (WDM)" Choose Properties. Navigate to the "Advanced tab" Un-tick the following checkbox "Allow applications to take exclusive control of this device"

Do the same for the checkbox on the "Recording tab".

share|improve this answer
    
Sometimes the playback also has gaps. A system restart then seems required. But I found that 'resetting' the E-MU card by changing the sample rate from 48 to 44 and back again also fixes it. –  E. van Putten Feb 21 at 15:39
    
Turns out I don't have a 0404 card, but a slightly different card 1010. But maybe the same workaround applies. –  E. van Putten Feb 21 at 15:40
    
Make sure that the sample rate that PatchMix displays (48-kHz) is also used by Windows itself. Patchmix: If you open PatchMix application there is a little button labeled "O" located on the top right corner of the window (next to the FX button). In the "System" tab you can set 48 kHz. Windows side of things: Go back to the playback/recording tabs. Make sure Windows is using the same samplerate as PatchMix to avoid unnecessary complexity and extra sample rate conversion. On the playback/recording tabs of the Windows sound device settings, make sure "16-bit, 48000 Hz (DVD Quality) is set. –  E. van Putten Feb 21 at 15:42
    
When recording with for instance Cool Edit, also record in 48kHz, not 44 kHz ! –  E. van Putten Feb 21 at 19:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.