Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Formatted my PC and installed SQL Server 2008. Setup hangs as shown in attached image.

install progress

The top text reads:

Running post-Windows Installer configuration timing actions

The bottom line says:


Installing on Window 7 64 bit OS. To install SQL Server SP1 is left to do due to this.

share|improve this question
how much memory do you have for this machine? Have you had another instance of SQL Server installed on the same box (i.e. 2005 evaluation edition)? – Fergus Oct 31 '10 at 18:49
@fergNab: No i have not any other instance installed. as i have formatteed pc this is first time i am installing SQL 08. Yes, i have installed Visual Studio 2010 before going for SQL 08. Thanks for the comment though!. Thanks – Romil N Oct 31 '10 at 19:14

3 Answers 3

up vote 1 down vote accepted

There is a known issue with SQL server and Visual Studio 2010. Michael Campbell has a great article "Why Can't SQL Server and Visual Studio Get Along?" that I think explains your problem.

share|improve this answer

There's a similar issue with SQL server 2012 hanging and a workaround here:

share|improve this answer
While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. – Dennis Jan 18 '13 at 3:56

Try restarting the Configuration Manager Remote Control service - it worked for me.

share|improve this answer
We’re looking for substantial answers that provide some explanation and context.  Don’t just give a one-line answer; explain why your answer is right, ideally with citations.  Answers that don’t include explanations may be removed.  To leave a friendly suggestion for an author, leave a comment below their post. – G-Man Apr 21 at 23:30
Its right because it worked, your thirst for theory is honourable but surplus to requirement, people come here for solutions, not a thesis. I tried it because the UI said it was hung on a process that mentioned "configuration". If you feel working solutions are a waste of the Internet then go ahead and delete this answer, I was just trying to help, what are you trying to do? – CAD bloke Apr 21 at 23:37

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.