Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So unexpectedly my volume control is missing from the system tray on Windows 7. I goto the start menu and type volume and choose "Show or hide volume (speaker) icon on the taskbar" and it's disabled in there and set to off. I then click "customize notification icons" at the bottom and on the list that shows up, I see at the bottom "Volume" with the dropbox icon over it.

Does dropbox obliterate my volume control on accident? Anyone else have anything like this? Got any other ideas for me to try?

forgot to mention: All the volume functions work, it's just the icon that's missing. I can control the volume by the keyboard or through the actual volume control (by pulling up the control panel widget). I just don't have the icon on the systemtray. All the rest of the system works tho.

share|improve this question
Can you still hear anything? Is the device still present in the device manager? – Tog Oct 31 '10 at 20:12
Sorry, yes, I meant to mention that: The volume control still works by the keyboard and everything else like that. I'll update the question. – jcolebrand Oct 31 '10 at 20:24

6 Answers 6

up vote 28 down vote accepted

This can happen from time to time, but it is very rare and usually a restart will fix it.

The three solutions to try are (in order of convenience):

  1. Restart the Windows Audio service.

    • open the Start menu
    • right-click on Computer and select Manage
    • navigate to "Services and Applications" → Services
    • right-click on Windows Audio and choose Restart

    alt text

  2. Restart Explorer.exe.

    • press Ctrl+Alt+Delete and select Task Manager
    • go to the Processes tab and find explorer.exe
    • right-click it and select "End Process". Make sure you do not have any file operations (copy/move etc.) going. Explorer should automatically restart.
    • If it doesn't, then in Task Manager, go to File → "New Task (Run...)", type in explorer, click OK and it should be back.

    alt text

  3. Restart the computer.

share|improve this answer
~ Thanks for the response. I'm not in front of the PC now, but I'll try later. I normally hibernate the machine, and I'm familiar with the methods given (restarting the shell, restarting the services) but is this a known issue with hibernating somehow? Once I've rebooted the machine (instead of hibernating) I'll let you know for sure if it did or did not fix it. – jcolebrand Nov 1 '10 at 15:21
@drachenstern The restart explorer option should fix it (It has every time I have seen the issue), I have never been able to track down what causes it as I only seem to see it once every two months or so and I do not think it is any one thing - but it is easily fixable. I do not think it is hibernate as I would see it a lot more often. – William Hilsum Nov 1 '10 at 15:36
Worked for me! Thanks :) – Kolky Feb 25 '13 at 10:21
For me both the power (battery) icon as well as the volume icon were missing. Restarting explorer.exe did the trick. – Andrew Cheong Dec 7 '13 at 20:00
May not occur as rarely as you think. +1 anyway. ;-) – martineau Mar 3 at 4:42

I'm running Windows 7. I could not quickly find 'Notification Area' in Control Panel, so I simply typed in "notification area" after clicking on the start button (lower left) Pick the first response,'Notification Area Icons'.
Choose 'turn system icons on or off'. You should be able to pick which ones to show. If the volume control is greyed out choose 'Restore default icon behaviours'.

And finally restart your computer.

share|improve this answer

Go to control Panel, in that open Notification Area Icons

In that window in the bottom side click on the Turn System icons on or off please select on in the icon behaviour of volume, and click ok

....that's it

share|improve this answer

Sorry to say, the patch I used is not compatible with Windows 7, but for your information, I have/had exactly the same problem with Windows XP. The problem has obviously carried over into Windows 7.

I came across this explanation for the XP problem:

this is caused by a timing defect in the Windows function Shell_NotifyIcon in shell32.dll, which has a timeout fixed at 4 seconds. Combined with an unfavorable Windows API message this causes the problem, which befalls many heavily loaded computers that don't have ultra-fast hard disks. Changing the timeout to one minute and removing the unwanted message solves the problem

The author provided a patch, which once installed, fixed the problem for me. Scroll to Main problem and complete solution section, which mentions:

nars has posted a patcher tool (direct download link )that solves the problem even for future versions and makes patching very easy and quick. Thanks a lot, nars!

share|improve this answer

I came across this and since none of these solutions worked for me, I thought I'd share what did (from here):

  1. Back up the Registry by creating a restore point.
  2. Go to Start > Run (or Windows-key + R), type in regedit and hit OK.
  3. Navigate to the key HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\TrayNotify.
  4. Delete the values IconStreams and PastIconsStream.
  5. Open up the Task Manager (Ctrl + Shift + Esc), go to the Processes tab, select explorer.exe and click End Process.
  6. Open the Applications tab and click New Task at the bottom-right of the window.
  7. In the message box that pops up type in explorer.exe and hit OK.
  8. Explorer.exe will reload, and the missing icons should now be back in the system-tray where they belong.
  9. Then if the volume bar isn't there, go to taskbar properties (where the volume was gray) and simply tick the box.
share|improve this answer

I have windows 7 Professional and restarting the service as was enough.
I believe this problem because of installing ubuntu on top.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.