Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

i was trying to install Linux on a old usb hard drive i have and i installed it onto the drive (from a .iso cd, i clicked install onto hard drive from the desktop) then rebooted. i tried to boot Linux from it but it did not work then i tried booting of the my main hard drive that has windows 7 on it and i get "failure to boot hard drive" (or something close to that). i reloaded fedora from the CD and looked and my main hard drive still has all of the files from windows and also the usb hard drive has files that look like they are from the Linux install. i do not know why it's giving me the hard drive error but i need to fix it fast because i need to do my school and it's on windows, any questions just ask.

share|improve this question

migrated from stackoverflow.com Oct 31 '10 at 22:06

This question came from our site for professional and enthusiast programmers.

1 Answer 1

You propably killed your MBR (Master Boot Record).

http://www.ehow.com/how_4836283_repair-mbr-windows.html

share|improve this answer
    
+1 - It's a common problem. But easily fixed thankfully. :) –  boehj May 5 '11 at 5:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.