Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm working with a T400 and Win7 32bit. Of course I can't use my 4GB memory. But the performance monitor shows me 1GB reserved memory for hardware.

Is there a way to reduce this? Maybe..turning off some features in the BIOS?

Greets

share|improve this question

1 Answer 1

It is not uncommon to find that your OS can only access 3.25Gb of RAM in a 32-bit environment, though it varies between chipsets and sometimes between OSs (on one of my older machines Windows got 3.25 and Linux somehow managed to squeeze out 3.5Gb - I never did work out what was different (the Widnows setup had all the correct official chipset drives and so forth), and on one headless machine Liunx managed ~3.75Gb though I never ran Widnows on there to see what it would manage to make available). So there may be nothing you can do - it could just be a fixed limitation of your laptop's chipset and drivers.

One factor that can make things significantly worse is graphics chipsets sharing main RAM rather than having their own pool. Many built-in graphics chips do this and some expension board ones do also and could be claiming 256Mb or even 512Mb. Being on a laptop does not neccesary mean your graphics chip is integrated, it may be on the same system board but considered a serpeate unit by the rest of the board and be using its own RAM, but check in your documentation for confirmation one way or the other and check your BIOS for options regarding graphics RAM allocation.

share|improve this answer
    
Thank you. So I'm at my hardware setup's mercy. I checked my BIOS and I'm not able to set a maximum memory for the embedded Intel graphics. My last hope. So depending on the whole setup I lost some RAM. Poor for working with VMs. –  steyze Nov 1 '10 at 13:11
    
Essentially yes, unless you use a 64-bit OS variant as your host OS (and even then, some chipsets have trouble with the last chunk of the first 4Gb). –  David Spillett Nov 1 '10 at 15:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.