Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I been having the following problem for a long time in Ubuntu 10.10.

What happens: When I right click I see the contextual but when I release this button it automatically clicks on the first option on this menu.

What Should happen: Normal behavior. Show the menu and then with left click (or right again) operate on said menu.

Extra information:

This is a USB mouse, is not a hardware error, it works in other computers, and in this same one perfectly when in Windows. This machine have a nvidia card. Using nvidia-current package. This problem is more prominent in Chromium and Java applications, also in "gnome-terminal".
UPDATE: in Firefox I get the expected behavior.

I tried already

*changing the InputDevice section of my xorg,
*changing setting in the BIOS (Asus motherboard) legacy USB support on and off.
*creating another user (clean .profile ,etc)
*log Gnome as "safe-mode" this means that compiz, and all other software isn't running

known workaround : click and hold the right button and then release on the chosen menu option.

link with people with the same problem:

http://ubuntuforums.org/showthread.php?t=1095706

Thanks so much in advance.

share|improve this question
up vote 1 down vote accepted

What you described as known workaround is a design decision. There seems to be no way to change the default behaviour.

This is also the case in newer Ubuntu versions.

Sources:

share|improve this answer

I found solution here: http://ubuntuforums.org/showpost.php?p=10468385&postcount=19

Just made my mouse left-handed and right-handed back again and it worked :)

share|improve this answer
    
It works now in all the windows except gnome terminal. (shoul i use kde?)) – ns-keip Apr 16 '11 at 3:53

Have you tried the solution in the last post of the discussion you mentioned? Links to this entry: http://ubuntuforums.org/showpost.php?p=1435048&postcount=5

share|improve this answer
    
I did, it didn't work. – OmniWired Nov 1 '10 at 10:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .