Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am running Ubuntu Netbook Remix 10.04. I have been having some problems recently with Pulseaudio, which has traditionally worked fine for me on this netbook actually.

Specifically, when I boot the computer, the system will play the "Bongo roll" sound at the GNOME login screen, telling me that sound hardware has been detected and should be working fine.

Yet when I log into the Netbook interface, my volume notification icon has the three blank lines indicating my session does not have access to the sound hardware. Nor do any of the built-in Sound preference panels detect my hardware, only registering dummy output. Finally, the (hopefully) deprecated PulseAudio Device Manager and Volume Control applications also fail to detect my hardware.

However, this problem is inconsistent! It will only happen on certain boots, though the number seems to be hovering around 75% of boots where pulseaduio fails to load correctly. The daemon/service is running, and restarting it only returns:

jmmcl2@unteer:~$ sudo service pulseaudio restart
* PulseAudio configured for per-user sessions

To ask again, why is my Pulseaudio being so selective about detecting my sound hardware in Ubuntu 10.04?

share|improve this question
add comment

1 Answer

I took a stab at the problem, and randomyl came up with a solution.

Curious about which processes were running, and wanting to start fresh, I ran

$>ps aux | grep pulse

and then killed the first process that looked related to pulse audio

/usr/bin/pulseaudio --start --log-target=syslog

Upon killing the process, which was running as my local user anyways, my volume indicator icon returned to normal, as did sounds. So technically the problem is fixed, but can anyone elaborate on what may have been causing it, and why killing the pulseaudio process restored sound...?

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.