Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In Excel 2003, It seems to be putting each spreadsheet I open into the existing Excel application as a new window. this makes it very difficult in a dual monitor set up to put one spreadsheet on each monitor.

Is there a way to force Excel to make a new instance of itself every time I open a new spreadsheet?

share|improve this question

migrated from stackoverflow.com Nov 2 '10 at 11:39

This question came from our site for professional and enthusiast programmers.

add comment

4 Answers

This will do what you want:

  1. Open the Registry Editor, browse to HKEY_CLASSES_ROOT\Excel.Sheet.8\shell\Open

  2. Delete the ddeexec key, (or just rename it if you are worried - I just renamed it and it worked)

  3. Click on the "command" key and replace the /e on the end of the (Default) and command strings in that key with "%1"

    The quotes around %1 are important and must be added.

    After the change the lines should look like this:

    (Default)   REG_SZ   "C:\Program Files (x86)\Microsoft Office\Office11\EXCEL.EXE" "%1 
    
    command   REG_MULTI_SZ   ']gAVn-}f(ZXfeAR6.jiEXCELFiles>!De@]Vz(r=f`1lfq`?R& "%1"
    
  4. Make the same changes to Excel.Sheet.12

Now both .xls and .xlsx should open in new windows with no errors.

share|improve this answer
add comment

If the files are static (on your desktop, My Docs, etc) then you can reference this link:

http://www.techonthenet.com/excel/questions/instance.php

If you have random files (from the Internet, E-Mail, etc) then you can do this to change the way it opens all XLS files to open in a new instance:

http://www.drewery.net/blog/2006/08/29/utilising-dual-monitors-with-microsoft-excel-2003/

share|improve this answer
    
I actually tried the Drewery link instructions a while ago and it didn't work, and now I get like 5 errors I have to click through before Excel opens :-( –  Greg Oct 17 '08 at 18:34
    
Did you also deselect the 'DDE' and 'OK' through it? Try pasting my path into it: "C:\Program Files\Microsoft Office\OFFICE11\EXCEL.EXE" /e "%1" –  JFV Oct 17 '08 at 18:54
    
Ok, that worked. Thanks! –  Greg Oct 17 '08 at 19:14
add comment

If you like the existing behavior of opening documents in the current instance, and occasionally need a second copy of Excel to run, you can just launch a second copy of Excel from your favorite shortcut and drag-and-drop in the file you want.

share|improve this answer
add comment

The following would work for Win7 64 bit,(right click excel and open in new instance submenu) Open a notepad and paste the following and save it as:- Excel OpenInNewInstance.reg and right click merge…. you are done.. right click your excels and open in new instance

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\Excel.Sheet.12\shell\OpenInNewInstance]
@="Open In New Instance"

[HKEY_CLASSES_ROOT\Excel.Sheet.12\shell\OpenInNewInstance\command]
@="\"C:\\Program Files (x86)\\Microsoft Office\\Office14\\EXCEL.EXE\" \"%1\""

[HKEY_CLASSES_ROOT\Excel.Sheet.8\shell\OpenInNewInstance]
@="Open In New Instance"

[HKEY_CLASSES_ROOT\Excel.Sheet.8\shell\OpenInNewInstance\command]
@="\"C:\\Program Files (x86)\\Microsoft Office\\Office14\\EXCEL.EXE\" \"%1\""
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.