Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've recently been forced to switch from Ubuntu over to Windows XP for my university studies and have installed the Aptana Studio 3 beta which looks good. I set it up with portable Git and have set my user and email in the usual way using the built-in console.

However, when I push to my GitHub repository, my commits have no author associated with them (shows as 'Unknown'). My email address on GitHub and in my Git config match but even if they didn't I would expect to see something other than 'Unknown'.

While technically this doesn't matter for this particular project (as I am the sole author) it would be nice to fix this for future projects.

As a side question: can I assign an author to commits which don't have one?

share|improve this question
add comment

2 Answers 2

up vote 1 down vote accepted

Find 'gitconfig' in Aptana Workspace.metadata.plugins\com.aptana.portablegit.win32\etc\' add the git [user] settings there. I'm not sure what other way there is to add [user] stuff in that plugin.

Keep in mind that, every time you update Aptana, (or I assume that plugin) the [user] setting will go away, so you have to put that in there again...

share|improve this answer
add comment

OP asked this a long time ago, but I just ran into the same problem, although it required a different solution. I'm noting it here in case anyone else runs into the same problem.

I am running Aptana on Win7x64, using msysgit installed separately from Aptana, as Aptana's git plugin still has version 1.7.3.1. Aptana's Preferences->Team->Git points to C:\Program Files (x86)\Git\bin\git.exe, and all git functionality works properly from Aptana's git bash shell. However, when doing a Push using the Team menu, the author was showing up as "Unknown."

I couldn't figure out what was wrong, and eventually stumbled on the log files in the Aptana project directory (aka local git repo) .git/logs directory. In the HEAD file I noticed that somebody (Aptana?) was inserting my local machine name into the user string, so it looked like

<me@mymachine.mydomain>

rather than

<me@mydomain>

Noticing this, I went to Github and modified my profile to include the <me@mymachine.mydomain> version as an alternate e-mail address (unverified, but whatever) and afterwards pushing from Aptana shows the correct user on the commit.

There may be a config setting somewhere that is incorrectly filled in with the <me@mymachine.mydomain> string, but I have yet to find it.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.