Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am having an issue with my computer. My IIS services are not working.

I have narrowed it down to the fact that my computer cannot find itself via its name.

I try pinging my computer by its name and I get this:

C:\Users\18773>ping MyComputerNameHere

Pinging MyComputerNameHere [::1] with 32 bytes of data:
PING: transmit failed. General failure.
PING: transmit failed. General failure.
PING: transmit failed. General failure.
PING: transmit failed. General failure.

Ping statistics for ::1:
    Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

I tried having someone else ping my machine and it works fine for them.

Any ideas?

share|improve this question
1  
when you ping over a network using a computer name, you are using WINS. Can you ping your computer by IP address? if so, then for some reason WINS translation is failing, if not, then something is going on with your network connection, but that is a place to start. – MaQleod Nov 2 '10 at 16:52
up vote 0 down vote accepted

Turns out that my computer somehow has decided that my local connection is IP v6.

Not sure why. All other pinging uses v4. Anyway, once I enabled v6 on my network card, it started working again (though it shows v6 IP addresses)

Wish I knew how to tell it to use IP v4 again, but at least it is working.

share|improve this answer

Since Vista and Server 2008, Windows prefers IPv6 whenever possible. In your case, Windows did prefer to lookup the AAAA record instead of the corresponding A record. Therefore, the host did ping ::1 and not 127.0.0.1 or any other IPv4 address.

How to disable the preference of IPv6: IPv4 vs IPv6 priority in Windows 7 at superuser.com.

There is a packaged solution available: MicrosoftEasyFix50410.msi. You can download it at microsoft.com. Look for Prefer IPv4 over IPv6 in prefix policies.

If you want to prevent ping from using IPv6 at all, then use the -4 option.

share|improve this answer
    
For future reference: MicrosoftEasyFix50410.msi can be found via article ID 929852. – user2964971 Dec 25 '15 at 11:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .