Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently sent my Macbook Pro (late 2008 model) to get a replaced logic board and top cover. When I got it back the Special function keys are mixed up.

F3 - mutes sound - it should do expose 
f4 - decreases volume - it should show the dashboard
f5 - increases volume ....etc,
...
F11 - expose - it should decrease volume
f12 - dashboard - it should increase volume

I have checked and made sure that System Preferences>Keyboard>"use all F keys as standard function keys" is not selected. And that no accessibility options are switched on either.

How do I fix this? or should I bring it back to the repair shop?

Thanks

share|improve this question
    
So what exactly is the behavior? You need to press Fn but it's set to not require Fn? Or is it always like this, Fn or not? –  Daniel Beck Nov 2 '10 at 18:40
    
It's not set to require fn. Even when I select that option it doesn't work properly either. The keys that have the volume pictures on them don't control volume etc. Its like the OS has mixed up the keys. –  seanieb Nov 2 '10 at 19:12

4 Answers 4

Apple has changed the keyboard firmware a number of times, rearranging the function key meanings. As far as I know, there is no way to go back to the old firmware.

It might be possible to convince KeyRemapper4MacBook to rearrange them to match the keycaps; see How to add new settings.

share|improve this answer
up vote 1 down vote accepted

The issue was hardware related. An older model to was installed with a newer keyboard. I brought it to a proper Apple store and they fixed the issue.

share|improve this answer

Try toggling the System Preferences, go to Keyboard (second row, Hardware), Keyboard (Tab), Toggle Use all F1, F2, etc. keys as standard function keys.. Maybe what's internally set and what's displayed are different.

share|improve this answer
    
Unfortunately this didn't work either. –  seanieb Nov 2 '10 at 18:26

Try resetting your PRAM, if you didn't already do so.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.