Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My computer is connected to my receiver using an HDMI cable and the DVI to HDMI adapter I received with the graphics card - ATI Radeon 4870. On my old system (Vista 64 bit) everything worked well, and the playback devices showed the HDMI output transfering 5.1 and it was indeed doing it (I could hear 5.1 audio out of the speaker system).

I recently installed Windows 7 64 bit, and installed the Realtek HD audio driver R2.14 which enables me to select 5.1 audio in the playback devices configuration window. this is the same procedure I did for my old system.

However even though it shows as if the output is 5.1 audio, it only outputs stereo. That is, when I test the rear speakers (click on their picture) the front speakers are playing. There is nothing wrong with the hardware (Computer, ATI card, receiver or speakers) since everything worked well on my old vista system.

How can I change it to true 5.1 audio?

share|improve this question
Unfortunately no. I cannot find the GUI interface anywhere ("Realtek Audio Manager"), and when i installed the latest Realtek HD Audio drivers I only had a "Stereo" option in playback devices. The R2.14 version of the drivers added the 5.1 and 7.1 options, but it doesn't work properly... – Fastas Nov 8 '10 at 5:19
i've only ever had stereo over hdmi - let me know if it works out. – RobotHumans Nov 8 '10 at 20:58

Have you tries using Windows own driver for your sound card? If there is any you can change the output under "Control Panel". Under Hardware Setting, right click your Sound Card and update the driver using MS drivers.

share|improve this answer
Yep, tried it, Windows' driver allows only stereo in the playback devices HDMI configuration... only Realtek ATI HDMI audio driver adds the 5.1 and 7.1 options (for me at least) – Fastas Nov 9 '10 at 11:11
up vote 0 down vote accepted

Found the solution, it was composed of two things:

  1. I noticed in the device manager that the driver that was installed was not the Realtek ATI HDMI driver, even though I installed it. So I updated the driver and choose the Realtek driver manually (I think it was called HDXATI64.inf, or something like that).

  2. The second problem was actually the receiver, which was not configured correctly for the computer's HDMI input (probably after a power cut), and was downmixing all the channels to stereo...

share|improve this answer
Did you need to restart the computer ? – Cyril Duchon-Doris Mar 5 '15 at 11:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .