Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I try to install Intel PROSet on Windows XP/32, then the installation process is aborted automatically, with a messages that PROSet is already installed.

However, this is not true. While PROSet had been installed on that system some time ago, I believe that it has been removed: There is no start-menu entry, it does not appear in Windows' "Add or Remove Programs", and neither does it seem to be in the program files folder, which I searched extensively.

Any idea how to install PROSet?

It's version, for an Intel PRO 2100 3B Mini PCI adapter.

One possible source of the problem: Some time ago, I installed a newer version of PROSet. But, as it it didn't support the aforementioned Wifi adapter, I deinstalled it completely.

Update: After de-installing the Intel drive package for the Ethernet adapter, I could install PROSet. However, PROSet doesn't start.

share|improve this question

Unfortunately i do not have any intel wireless controllers to try this with, but some of the steps outlined here may help.

share|improve this answer
Thanks! However, DxSetup.exe is not included with the version of PROSet that I try to install. I then tried the command line install using msiexec.exe. However, the same problem as before, and the log doesn't give any valuable information. I also tried uninstalling using msiexec.exe, but - as expected - I get a message that the software is not installed. – feklee Nov 3 '10 at 16:43
do you need the intel specific software, or just the driver for the hardware? – Xantec Nov 3 '10 at 16:55
I have problems with the wifi tool built into XP. For example, it often doesn't find wifi networks nearby, and I have to scan several times in a row. So, I hope that the Intel tool is a solution. It may have a different timeout when scanning, or it may even allow setting a timeout. But there are more issues. – feklee Nov 3 '10 at 17:04

I've had this problem, and figured out what was going on.

Intel ProSet is actually a licensed version of another company's software. Other companies (Marvell or maybe Realtek) also license it for use with their networking hardware. If any version has been installed, even if it is "properly" uninstalled, another version will not install.

I put properly in quotes, because this software leaves registry keys behind that indicate it is still installed, even after running the uninstaller.

The solution is to clean your registry. I'm sorry, but it has been a while and I don't recall the exact keys, but CCleaner should help you find them.

share|improve this answer
Thanks this looks interesting! In fact, yesterday, I already removed some keys related to PROSet, but with no effect. – feklee Nov 4 '10 at 14:21
up vote 0 down vote accepted

After juggling with the drivers for the Intel devices PRO/2100 3B (Wifi) and PRO/1000 MT (Ethernet), and PROSet, I finally got it to work:

  • Intel driver for PRO/1000 MT, version

  • Intel driver for PRO/2100 3B, version

  • Intel PROSet, version

The PRO/1000 MT driver comes with some "PROSet component" that conflicts with the PROSet software for the Wifi adapter. I deinstalled that component, then I was able to install PROSet.

Fortunately, further tests confirmed that the suspicion mentioned by kmarsh turned out to be not true: That I installed and removed a later version of PROSet has caused no trouble.

Whether the above is a stable setup remains to be proven.

share|improve this answer
There definitely WAS a problem with PROSet re-installs at one time; I reported this as a bug, I'm hoping your experience shows that this is fixed! – kmarsh Nov 23 '10 at 14:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .