Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently bought a new My Book Essential 1TB (WDBACW0010HBK-NESN) to daisychain to my older My Book World Edition 500GB (blue rings) with one of the version 01.xx.xx firmwares.

At first when I connected the USB drive to the MBWE, it showed up in the System Summary section of the administration page without any issue. I was able to set up a new share on the new drive. The administration website moved very, very slow though. The administration pages became nearly unresponsive during this setup process. Once the share was set up I could access the new share but again, it was very slow, now through Windows Explorer. I looked around the internet and it seems that this is caused by the USB drive being formatted with NTFS. I tried reformatting it (again, as NTFS) just to double check and the same problem occurred. I then tried FAT32 but realized it would only support files of approximately 2GB and that is not acceptable for me.

I decided to try a firmware upgrade on the MBWE to version 02.00.19. The firmware upgrade completed successfully but now the MBWE does not display the USB drive in the System Summary like it did with the earlier firmware version. The USB drive works perfectly fine when connected directly to my computer.

Is there a way to solve this issue?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

I emailed Western Digital tech support and they responded to let me know that this setup will not work properly.

We apologize for the difficulties. Your My Book World Edition (Blue Rings) only supports USB drives up to 500 GB (its own capacity) formatted as FAT32 (NTFS will appear as read-only).

The My Book Essential (+ WD SmartWare) USB 3.0/USB 2.0 is not supported by the My Book World Edition (Blue Rings). Please connect your drive directly to the computer.

With that said, I'm wondering if there might be a way to hack the firmware so I can get it to recognize NTFS without messing anything up.

share|improve this answer

I am not too familiar with this particular product, and i am probably even less familiar with linux; however, it is possible that one or both of these resources may have what you are looking for, if you are willing to do a little digging.

Hacking WD MyBook World Ed
Hacking Western Digital MyBook World Edition

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.